Topic
  • 7 replies
  • Latest Post - ‏2013-01-25T20:38:05Z by P6HA_Jean-Philippe_DURNEY
P6HA_Jean-Philippe_DURNEY
5 Posts

Pinned topic Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

‏2013-01-11T16:15:08Z |
I have installed the latest version of Big Insight Enterprise Edition on a RHEL 6.2 on X86.
The installation directory after unpacking is : biginsights-enterprise-linux64_b20121203_1915

After launching ./start.sh, I've got an error when I tried to access to the page http://X.X.X.X:8300/Install/

Here is the error message in my browser (Same error with IE, Firefox):
HTTP Status 404 - /Install/

type Status report

message /Install/

description The requested resource (/Install/) is not available.
Apache Geronimo(Embedded Tomcat/6.0.33)

What can I do ?
Thanks
JP
Updated on 2013-01-25T20:38:05Z at 2013-01-25T20:38:05Z by P6HA_Jean-Philippe_DURNEY
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

    ‏2013-01-11T17:34:33Z  
    Hi JP,

    Please check server.log and server.out within the following directory:

    ../biginsights-enterprise-linux64_b20121203_1915/installer-console/var/log

    Those logs may contain some clues.

    Let us know what you find.

    Thanks,
    Zach
  • P6HA_Jean-Philippe_DURNEY
    5 Posts

    Re: Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

    ‏2013-01-14T09:39:59Z  
    Hi JP,

    Please check server.log and server.out within the following directory:

    ../biginsights-enterprise-linux64_b20121203_1915/installer-console/var/log

    Those logs may contain some clues.

    Let us know what you find.

    Thanks,
    Zach
    Hi Zach,

    I have unpacked the install file and restart the start.sh Shell to get the smallest lof file, and I get the same behavior when I try to go to http://X.X.X.X:8300/Install.
    I didn't see any clue help full for me in the log file.
    Can you have a look in the 2 files I joined ? (the server.out is in the next reply.)
    Thanks
    JP

    Attachments

  • P6HA_Jean-Philippe_DURNEY
    5 Posts

    Re: Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

    ‏2013-01-14T09:40:17Z  
    Hi Zach,

    I have unpacked the install file and restart the start.sh Shell to get the smallest lof file, and I get the same behavior when I try to go to http://X.X.X.X:8300/Install.
    I didn't see any clue help full for me in the log file.
    Can you have a look in the 2 files I joined ? (the server.out is in the next reply.)
    Thanks
    JP
    The server.out file
    Thks
    JP

    Attachments

  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

    ‏2013-01-14T17:45:40Z  
    The server.out file
    Thks
    JP
    Hi JP,

    Unfortunately, the logs don't see to show the error.

    Let's try the following:

    1) Please run ./start.sh and copy paste the entire output of the command and we can take a look.

    2) Was also wondering what utility did you use to uncompress the installer.
    If anything other than tar command, maybe you can try uncompress again using the following command, to make sure there are no corruptions.

    tar -xvf file.tar

    Thank you,

    Zach
  • P6HA_Jean-Philippe_DURNEY
    5 Posts

    Re: Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

    ‏2013-01-15T15:22:42Z  
    Hi JP,

    Unfortunately, the logs don't see to show the error.

    Let's try the following:

    1) Please run ./start.sh and copy paste the entire output of the command and we can take a look.

    2) Was also wondering what utility did you use to uncompress the installer.
    If anything other than tar command, maybe you can try uncompress again using the following command, to make sure there are no corruptions.

    tar -xvf file.tar

    Thank you,

    Zach
    Hi Zach,

    Here is the output of the start.sh Script : (I have just change the IP in the text)

    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915# ./start.sh
    artifacts/ibm-java-sdk-6.0-11.0-linux-x86_64.tgz
    Extracting Java ....
    Java extraction complete, using JAVA_HOME=/root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915/_jvm/ibm-java-x86_64-60
    Verifying port 8300 availability
    port 8300 available
    Starting BigInsights Installer .....
    Application server is up and running...
    BigInsights Installer started, please use a browser to access:
    http://X.X.X.X:8300/Install

    After you are finished, run the following command to stop the installer web server:
    start.sh shutdown
    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915#

    I have use gunzip and tar -xvf to uncompress the BIGINSIGHT_ENTPR_ED_V2.0_LNX.tar.gz file.
    May be it can help when I do a start.sh Shudown, I have a warning :
    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915# ./start.sh shutdown
    artifacts/ibm-java-sdk-6.0-11.0-linux-x86_64.tgz
    Using GERONIMO_HOME: /root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915/installer-console
    Using GERONIMO_TMPDIR: var/temp
    Using JRE_HOME: /root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915/_jvm/ibm-java-x86_64-60/jre
    log4j:WARN No appenders could be found for logger (org.apache.geronimo.kernel.basic.BasicKernel).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    Locating server on localhost:1319... Server found.
    Server shutdown started
    Server shutdown completed
    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915#

    Thanks in advance
    JP
  • SystemAdmin
    SystemAdmin
    603 Posts

    Re: Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

    ‏2013-01-22T17:56:53Z  
    Hi Zach,

    Here is the output of the start.sh Script : (I have just change the IP in the text)

    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915# ./start.sh
    artifacts/ibm-java-sdk-6.0-11.0-linux-x86_64.tgz
    Extracting Java ....
    Java extraction complete, using JAVA_HOME=/root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915/_jvm/ibm-java-x86_64-60
    Verifying port 8300 availability
    port 8300 available
    Starting BigInsights Installer .....
    Application server is up and running...
    BigInsights Installer started, please use a browser to access:
    http://X.X.X.X:8300/Install

    After you are finished, run the following command to stop the installer web server:
    start.sh shutdown
    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915#

    I have use gunzip and tar -xvf to uncompress the BIGINSIGHT_ENTPR_ED_V2.0_LNX.tar.gz file.
    May be it can help when I do a start.sh Shudown, I have a warning :
    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915# ./start.sh shutdown
    artifacts/ibm-java-sdk-6.0-11.0-linux-x86_64.tgz
    Using GERONIMO_HOME: /root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915/installer-console
    Using GERONIMO_TMPDIR: var/temp
    Using JRE_HOME: /root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915/_jvm/ibm-java-x86_64-60/jre
    log4j:WARN No appenders could be found for logger (org.apache.geronimo.kernel.basic.BasicKernel).
    log4j:WARN Please initialize the log4j system properly.
    log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
    Locating server on localhost:1319... Server found.
    Server shutdown started
    Server shutdown completed
    root@psscbig0 biginsights-enterprise-linux64_b20121203_1915#

    Thanks in advance
    JP
    Hi JP,

    In start.sh we have the following line, which caused the issue with your installation -

    INSTALL_APP=`$prog_path/$ui_directory/bin/deploy.sh -u system -p manager -port $ctrlport list-modules | grep "Install"`

    The reason this line is an issue, because your path to installation program has "Install" keyword, and we would pick up a wrong path.

    /root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915
    To following code change in start.sh should fix the issue:

    #INSTALL_APP=`$prog_path/$ui_directory/bin/deploy.sh -u system -p manager -port $ctrlport list-modules | grep "Install"`
    INSTALL_APP=""

    Thanks,

    Zach
  • P6HA_Jean-Philippe_DURNEY
    5 Posts

    Re: Problem Installing Big Insight 2.0 : Host:8300/Install/ not found

    ‏2013-01-25T20:38:05Z  
    Hi JP,

    In start.sh we have the following line, which caused the issue with your installation -

    INSTALL_APP=`$prog_path/$ui_directory/bin/deploy.sh -u system -p manager -port $ctrlport list-modules | grep "Install"`

    The reason this line is an issue, because your path to installation program has "Install" keyword, and we would pick up a wrong path.

    /root/InstallBigInsight/biginsights-enterprise-linux64_b20121203_1915
    To following code change in start.sh should fix the issue:

    #INSTALL_APP=`$prog_path/$ui_directory/bin/deploy.sh -u system -p manager -port $ctrlport list-modules | grep "Install"`
    INSTALL_APP=""

    Thanks,

    Zach
    Hi Zach,
    Thanks for finding the Solution.
    I have renamed the directory where I put the installation directory.
    It works now.
    Thanks
    JP