Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
5 replies Latest Post - ‏2013-02-16T11:35:35Z by Novikov_Alexander
SystemAdmin
SystemAdmin
3234 Posts
ACCEPTED ANSWER

Pinned topic Strange problem with QLogic FC controllers

‏2013-01-11T14:55:33Z |
Hello,

I`ve got huge problem with Qlogic 26K4859 adapters.
My hardware configuration is: HS21 8853Z34 Blade Servers, Infortrend A16F-G1A2 Array and 26K6479 Fibre switch.
When I power on my server and enter Qlogic BIOS I can see FC device in FC Switch management but when I do "scan fibre devices" in QLogic BIOS there are no devices present on the list. Of course I`ve got confgured Zone Set on FC switch and LUN Mapping in Infortrend Array. Strange thing is that I`ve got a couple of 26K4859 adapters and some of them (installed in the same HS21 server, in the same bay, the same QLogic BIOS settings, assigned to the same disk resource in the same Array) do see FC device in BIOS but some of them don`t :/ Of course I`ve upgraded QLogic BIOS'es, restored settings to default but the problem still persists.

My adapter settings:
BIOS Address: D2E00
Bios Revision: 1.54
Adapter Serial Number: C97167
Interrupt Level: 11
Adapter port Name: 210000145e24xxxx
Host Adapter BIOS: Disabled
Frame Size: 2048
Loop Reset Delay: 5
Adapter Hard Loop ID: Enabled
Hard Loop ID: Enabled
Hard Loop ID: 125
Spinup Delay: Disabled
Connection Options: 2
Fibre Channel Tape Support: Enabled
Data Rate: 2

Advanced Adapter Settings:
Execution Throttle: 256
Luns per Target: 0
Enable LIP Reset: No
Enable LIP Full Login: yes
Enable Target Reset: Yes
Login Retry Count: 30
Port Down Retry Count: 30
Link Down Timeout: 30
Extended Error Logging: Disabled
Operation Mode: 0
Interrupt Delay Timer: 0
EV Boot Order: Disabled
For example:
I get #1 QLogic Controller and put into #1 HS21 Serwer into #1 bay and connect it to #1 LUN in Array - it works. So it means that #1 controller, #1 HS21 server, #1 bay, FC switch and #1 LUN in array are ok and confugured properly.

Then I get #2 QLogic Controller and put it into #1 HS21 Serwer into #1 bay and connect it to #1 LUN in Array - it doesn't work. The only thing I've changed is QLogic Controller so it`s probably broken.

Then I put #1 QLogic Controller and put into #2 HS21 Serwer into #2 bay and connect it to #2 LUN in Array - it works.

Then I get #2 QLogic Controller and put it into #2 HS21 Serwer into #2 bay and connect it to #2 LUN in Array - it doesn't work - again this means that #2 QLogic controller is broken.

But from the switch side it looks normal. There are some decode errors but when I`m tryging working controller there are some decode errors too.

Do you have any idea how to solve this issue? Is it possible that some of my QLogic controllers are simply broken?
Updated on 2013-02-16T11:35:35Z at 2013-02-16T11:35:35Z by Novikov_Alexander
  • Novikov_Alexander
    Novikov_Alexander
    1147 Posts
    ACCEPTED ANSWER

    Re: Strange problem with QLogic FC controllers

    ‏2013-01-16T07:16:04Z  in response to SystemAdmin
    Dear Lukasz,

    could you provide DSA log of your problem server, AMM Service Data from BladeCenter, output of command supportshow from both Brocade FC switch modules and DS Support Data from storage.

    Regards,
    Alexander Novikov
    Russia, Moscow
    • SystemAdmin
      SystemAdmin
      3234 Posts
      ACCEPTED ANSWER

      Re: Strange problem with QLogic FC controllers

      ‏2013-01-16T10:54:54Z  in response to Novikov_Alexander
      Dear Alexander,
      You can download DSA log and Support File from FC switch here:
      http://www.sendspace.pl/file/16b0ed21f384dc900c31c08
      HS21 test server with FC controller is located in 6th bay.
      Unfortunately I`m unable to capture AMM Service Data from BladeCenter because we`ve got SBCECMM Management Module. AFAIK to capture AMM Service Data Advanced Management Module is required, am I right?
      I`m also unable to gather DS Support Data from Infortrend A16F-G1A2 Array :/
      Regards,
      Lukasz Zak
      • Novikov_Alexander
        Novikov_Alexander
        1147 Posts
        ACCEPTED ANSWER

        Re: Strange problem with QLogic FC controllers

        ‏2013-01-18T15:11:55Z  in response to SystemAdmin
        Dear Lukasz,

        first of all update all server's software:

        IBM BIOS Flash Update v1.22
        IBM Preboot Diagnostics Flash Update v1.08
        LSI 1064e SAS Controller BIOS and Firmware v1.18.86.00
        Baseboard Management Controller (BMC) v1.23
        Online Broadcom NetXtreme Firmware v4.6.1
        QLogic HBA BIOS/firmware 2.16/5.03.06

        If it not helped, post updated DSA log.

        What is the FC switches in this SBCECMM?

        Regards,
        Alexander Novikov
        Russia, Moscow
        • SystemAdmin
          SystemAdmin
          3234 Posts
          ACCEPTED ANSWER

          Re: Strange problem with QLogic FC controllers

          ‏2013-02-15T10:12:31Z  in response to Novikov_Alexander
          I`ve tested with the newest updates before. Anyway I found working combination of FW versions and settings, now everything works fine. Thank you for your support.
          • Novikov_Alexander
            Novikov_Alexander
            1147 Posts
            ACCEPTED ANSWER

            Re: Strange problem with QLogic FC controllers

            ‏2013-02-16T11:35:35Z  in response to SystemAdmin
            Hi Lukasz,

            you are welcome.

            Regards,
            Alexander Novikov
            Russia, Moscow