Topic
2 replies Latest Post - ‏2013-01-17T21:53:44Z by giovanni.vigorelli@it.ibm.com
giovanni.vigorelli@it.ibm.com
8 Posts
ACCEPTED ANSWER

Pinned topic WL 505 - dojo.js 404 not found

‏2013-01-10T11:22:51Z |
Hi There,

I've create a sample project with dojo framework.
Adding just some HTML objects (couple of views and a list) using the dojo palette, when I deploy and test the app, the browser gets a white page in the browser js console I got following errors:

Failed to load resource: the server responded with a status of 404 (Not Found) http://localhost:8080/apps/services/preview/test/common/0/default/dojo/dojo.js
wlclient init started worklight.js:1097
before: app init onSuccess worklight.js:1097
Uncaught ReferenceError: require is not defined test.js:14
wlCommonInit test.js:14
wlInit wlclient.js:1030
finalizeInit wlclient.js:243
init wlclient.js:1187
(anonymous function) initOptions.js:36

I created a brand new project and without any coding, deploying and testing (preview from the WL console embedded in the Studio), I have the same errors in the js console (but the app name is rendered in the browser).

Any idea about this problem?

Cheers, Giovanni
  • raanan
    raanan
    50 Posts
    ACCEPTED ANSWER

    Re: WL 505 - dojo.js 404 not found

    ‏2013-01-17T14:43:31Z  in response to giovanni.vigorelli@it.ibm.com
    Hi Giovanni.

    Can you please check that you have the folder dojo created under the project folder and in your HTML file there is the line:
    <script type="text/javascript" data-dojo-config="isDebug: false, async: true, parseOnLoad: true, mblHideAddressBar: false" src="dojo/dojo.js"></script>
    • giovanni.vigorelli@it.ibm.com
      8 Posts
      ACCEPTED ANSWER

      Re: WL 505 - dojo.js 404 not found

      ‏2013-01-17T21:53:44Z  in response to raanan
      Hi Raana,

      thanks for your suggestion, but after a day I give up with troubleshooting and I tried to reinstall Eclipse and WL Studio. This solved the problem.

      Cheers, Giovanni