Topic
  • 3 replies
  • Latest Post - ‏2013-01-09T14:32:02Z by SystemAdmin
SystemAdmin
SystemAdmin
881 Posts

Pinned topic SPSS 20 takes 10 minutes to start

‏2013-01-09T11:55:01Z |
Hello SPSS users,

My SPSS 20 takes 10 minutes to launch. Would you know how to solve it?

Some additional information:

My computer is a new Toshiba, 64-bit, Windows 7. It has Java 6. I had to downgrade it from 7 due to a conflict with a different software I am using.

Has anyone had similar problem? Would you know what can be the cause?

All the best,
Danusia
  • SystemAdmin
    SystemAdmin
    881 Posts

    Re: SPSS 20 takes 10 minutes to start

    ‏2013-01-09T13:50:26Z  
    Statistics installs it own copy of the JRE, so other Java versions you have installed are irrelevant.

    Things that could cause a delay might include
    • loading over a slow network connection
    • remote license server that is not responding promptly
    • antivirus software - you could exclude the Statistics directory from scans
    • firewall blocking starting the help system.
    • a very slow startup autoscript

    If you watch Statistics start in the Task Manager (add columns using the View menu) you can see when the three processes start and consume resources
    stats.exe - front end
    spssengine.exe - back end
    javaw.exe - help system launch.

    You will probably need to talk to Technical Support to pursue this further.

    HTH,
    Jon Peck
  • SystemAdmin
    SystemAdmin
    881 Posts

    Re: SPSS 20 takes 10 minutes to start

    ‏2013-01-09T14:13:58Z  
    Statistics installs it own copy of the JRE, so other Java versions you have installed are irrelevant.

    Things that could cause a delay might include
    • loading over a slow network connection
    • remote license server that is not responding promptly
    • antivirus software - you could exclude the Statistics directory from scans
    • firewall blocking starting the help system.
    • a very slow startup autoscript

    If you watch Statistics start in the Task Manager (add columns using the View menu) you can see when the three processes start and consume resources
    stats.exe - front end
    spssengine.exe - back end
    javaw.exe - help system launch.

    You will probably need to talk to Technical Support to pursue this further.

    HTH,
    Jon Peck
    Hello John,

    Thanks a lot for your answer.

    I actually followed stat.exe in the processes and it starts straight away after I launch SPSS. However, it doesn't consume any resources at the beginning - for around 10 minutes it's there on 0 CPU. What may be the cause?

    Also, I don't think I have a remote license. I have licensed SPSS through my organisation (second option on the licensing menu). In this case would SPSS still need to contact licensing server every time I launch it?

    I will keep an eye on other processes you have mentioned.

    All the best,
    Danusia
  • SystemAdmin
    SystemAdmin
    881 Posts

    Re: SPSS 20 takes 10 minutes to start

    ‏2013-01-09T14:32:02Z  
    Hello John,

    Thanks a lot for your answer.

    I actually followed stat.exe in the processes and it starts straight away after I launch SPSS. However, it doesn't consume any resources at the beginning - for around 10 minutes it's there on 0 CPU. What may be the cause?

    Also, I don't think I have a remote license. I have licensed SPSS through my organisation (second option on the licensing menu). In this case would SPSS still need to contact licensing server every time I launch it?

    I will keep an eye on other processes you have mentioned.

    All the best,
    Danusia
    Talk to your system admin. You may have a network license that has to be checked each time Statistics starts, and the license server might not be responding in a reasonable way.

    You might also get some useful information by running
    SHOW LICENSE.
    from the syntax window.