Topic
2 replies Latest Post - ‏2013-01-08T08:35:37Z by SystemAdmin
SystemAdmin
SystemAdmin
1807 Posts
ACCEPTED ANSWER

Pinned topic After installation, Req Pro 7.1.2.4 does not start

‏2013-01-07T13:34:34Z |
Happy New Year,

I use Reqpro 7.1.2.4 on Win 7, after installation, it does not start with error message Title Small Talk (Programming language ?) non-continuable protection violation occured. Check Error File:

Error log timestamp 1/7/2013 14:17:40
Message 1001:
a non-continuable protection violation has occurred. Check ERROR.LOG file.
Error log timestamp 1/7/2013 14:18:28

The registers were:
EIP = 0x02a7020d
ESP = 0x0018feac
EBP = 0x00000000
EAX = 0x08fc4444
EBX = 0xffffe001
ECX = 0x00000100
EDX = 0x0008e3c8
EDI = 0x00000001
ESI = 0x08fc4444
CS = 0x00000023
DS = 0x0000002b
ES = 0x0000002b
SS = 0x0000002b
End Registers
What can you read out of the hex values and the keys ?
Why is the error log timestamp with the registers one minuter later than the message timestamp ? Does it mean that it is a very heavy error ?
I started it as admin, I excluded it from the Data Exection prevention.

How to start the programme ?
Updated on 2013-01-08T08:35:37Z at 2013-01-08T08:35:37Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1807 Posts
    ACCEPTED ANSWER

    Re: After installation, Req Pro 7.1.2.4 does not start

    ‏2013-01-07T13:56:07Z  in response to SystemAdmin
    It is very urgent, because we need the validation. I enclose the xml response file for you to have more info:
    <?xml version="1.0" encoding="UTF-8"?>
    <agent-input temporary='true'>
    <server>
    <!--the repository/directory with the installation files-->
    <repository location='I:\1_MR\>
    </server>
    <!--Destination folder-->
    <profile id='IBM Rational SDLC' installLocation='C:\Rational'>
    <data key='eclipseLocation' value='C:\Rational'/>
    <data key='user.import.profile' value='false'/>
    <!-- Operating System -->
    <data key='cic.selector.os' value='win32'/>
    <!--Working System-->
    <data key='cic.selector.ws' value='win32'/>
    <data key='cic.selector.arch' value='x86'/>
    <data key='user.Team_Conv_InstallDirectory' value='C:/Rational'/>
    <!-- Sprache-->
    <data key='cic.selector.nl' value='en'/>
    <!-- Lizenzserver-->
    <data key='user.RCL_PortAtHost' value='>
    </profile>
    <install modify='false'>
    <offering id='com.ibm.rational.reqpro' version='7.1.2004.0000-7-1-2-04-00-2011C-D110822' profile='IBM Rational SDLC' features='com.ibm.rational.reqpro.checkv7.feature,com.ibm.rational.reqpro.check.processes.feature,com.ibm.rational.reqpro.antivirus.feature,com.ibm.rational.reqpro.lkad.removal.warning.feature,com.ibm.rational.reqpro.top' installFixes='none'/>
    </install>
    <preference name='com.ibm.cic.common.core.preferences.eclipseCache' value='C:\Program Files (x86)\IBM\IMShared'/>
    <preference name='com.ibm.cic.common.core.preferences.connectTimeout' value='30'/>
    <preference name='com.ibm.cic.common.core.preferences.readTimeout' value='45'/>
    <preference name='com.ibm.cic.common.core.preferences.downloadAutoRetryCount' value='0'/>
    <preference name='offering.service.repositories.areUsed' value='false'/>
    <preference name='com.ibm.cic.common.core.preferences.ssl.nonsecureMode' value='false'/>

    <!-- Connect and Read Timeout sowie downloadAutoRetryCount standard - Werte-->
    <preference name='com.ibm.cic.common.core.preferences.connectTimeout' value='30'/>
    <preference name='com.ibm.cic.common.core.preferences.readTimeout' value='45'/>
    <preference name='com.ibm.cic.common.core.preferences.downloadAutoRetryCount' value='0'/>
    <preference name='offering.service.repositories.areUsed' value='false'/>
    <preference name='com.ibm.cic.common.core.preferences.ssl.nonsecureMode' value='false'/>
    <preference name='com.ibm.cic.common.core.preferences.http.disablePreemptiveAuthentication' value='false'/>
    <!-- Gibt den Typ des verwendeten Authentifizierungsschemas an. NTLM ist der Standardwert. -->
    <preference name='http.ntlm.auth.kind' value='NTLM'/>
    <preference name='http.ntlm.auth.enableIntegrated.win32' value='true'/>
    <preference name='com.ibm.cic.common.core.preferences.preserveDownloadedArtifacts' value='true'/>
    <preference name='com.ibm.cic.common.core.preferences.keepFetchedFiles' value='false'/>
    <preference name='PassportAdvantageIsEnabled' value='false'/>

    <!-- Es soll nicht nach Updates gesucht werden -->
    <preference name='com.ibm.cic.common.core.preferences.searchForUpdates' value='false'/>
    <preference name='com.ibm.cic.agent.ui.displayInternalVersion' value='false'/>

    </agent-input>
  • SystemAdmin
    SystemAdmin
    1807 Posts
    ACCEPTED ANSWER

    Re: After installation, Req Pro 7.1.2.4 does not start

    ‏2013-01-08T08:35:37Z  in response to SystemAdmin
    I reinstalled it and now it works. God knows what the mistake was.
    But:
    I have a Win 64 bit System 7, but in the response file that I got there is:
    <data key='cic.selector.os' value='win32'/>

    So in the xml, it is a 32 bit. Do I have to change it to 64 bit ?

    What about these:
    <data key='cic.selector.ws' value='win32'/>
    <data key='cic.selector.arch' value='x86'/>

    working system is also 64 ? - architecture is x86 or x64

    I understand that x86 means 32 bit. My architecture = operation system is 64..

    I have two improvements for your developer work tool:
    It should be possible to edit his posts after they were written
    Code should be highlighted so that it is separated from normal text