Topic
  • 1 reply
  • Latest Post - ‏2013-01-07T12:13:14Z by flodstrom
RAMESH KUMAR JAKKEPALLY
1 Post

Pinned topic GPFS service is not starting: openssl issue

‏2013-01-07T07:35:13Z |
Hi,

I have 2 different cluster in my network and want to mount the file system of cluster 1 on second cluster.

I followed below link to do the same

http://publib.boulder.ibm.com/infocenter/clresctr/vxrx/index.jsp?topic=%2Fcom.ibm.cluster.gpfs.v3r5.0.7.gpfs200.doc%2Fbl1adv_admrmsec.htm

after making changes GPFS service is not starting, find the log below:

root@ddn01n3:/>tail -f /var/adm/ras/mmfs.log.latest
Mon Jan 7 00:58:17.641 2013: GPFS: 6027-788 Failed to load or initialize security library.
Mon Jan 7 00:58:17.653 2013: Command: err 721: mount ddn01n1-ml0:testgpfs 160230
Mon Jan 7 00:58:17.665 2013: GPFS: 6027-788 Failed to load or initialize security library.
Mon Jan 7 00:58:31.798 2013: Command: mount ddn01n1-ml0:testgpfs 74140
Mon Jan 7 00:58:31.999 2013: Failed to open OpenSSL library: (dlerror) 0509-022 Cannot load module /usr/lib/libssl.a.
0509-103 The module has an invalid magic number.
Mon Jan 7 00:58:32.035 2013: Failed to load and initialized OpenSSL library: err 721
Mon Jan 7 00:58:32.047 2013: GPFS: 6027-788 Failed to load or initialize security library.
Mon Jan 7 00:58:32.059 2013: Command: err 721: mount ddn01n1-ml0:testgpfs 74140
Mon Jan 7 00:58:32.071 2013: GPFS: 6027-788 Failed to load or initialize security library.

commands output:

root@ddn01n3:/>mmlsconfig
Configuration data for cluster ddn01n3-ml0:

myNodeConfigNumber 1
clusterName ddn01n3-ml0
clusterId 723398246350994329
autoload no
minReleaseLevel 3.4.0.7
dmapiFileHandleSize 32
maxblocksize 4096K
openssllibname /usr/lib/libssl.a
cipherList AUTHONLY
adminMode central

File systems in cluster ddn01n3-ml0:

/dev/ddngpfs
root@ddn01n3:/>
root@ddn01n3:/>mmgetstate -a

Node number Node name GPFS state

1 ddn01n3-ml0 down
2 ddn01n4-ml0 down
3 iitm03n13-ml0 down
4 iitm04n9-ml0 down
root@ddn01n3:/>

appreciate your quick help on this.

Regards,
Ramesh
Updated on 2013-01-07T12:13:14Z at 2013-01-07T12:13:14Z by flodstrom
  • flodstrom
    flodstrom
    115 Posts

    Re: GPFS service is not starting: openssl issue

    ‏2013-01-07T12:13:14Z  
    You should post this in the GPFS forum.

    Anyway, I don't think the openssllibname setting is correct? At least for me it looks supicious, but then I haven't used v3.5 yet (still on v3.4) so I might be wrong? Search the faq and/or documentation regarding OpenSSL and GPFS on AIX, you should find all you need to know there.

    You might also want to consider using the AIX toolbox version (freeware) of OpenSSL, I use that on the system I look after.