Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
13 replies Latest Post - ‏2013-02-07T23:54:32Z by SystemAdmin
SystemAdmin
SystemAdmin
300 Posts
ACCEPTED ANSWER

Pinned topic Error in installing Worklight in Eclipse

‏2013-01-03T12:51:07Z |
The below error is coming while installing Worklight in Eclipse.

Cannot complete the install because one or more required items could not be found.
Software being installed: IBM jQuery Mobile Tools 5.0.5001.v20121214_1542 (com.ibm.webtools.jquery.tools.feature.feature.group 5.0.5001.v20121214_1542)
Missing requirement: IBM Web Editor Common 1.1.0.v20121012_0113 (com.ibm.etools.webtools.webedit.common 1.1.0.v20121012_0113) requires 'bundle com.ibm.icu [4.2.1,5.0.0)' but it could not be found
Cannot satisfy dependency:
From: Rich Page Editor - jQuery extensions 1.0.0.v20121022_1611 (com.ibm.etools.rpe.jquery 1.0.0.v20121022_1611)
To: bundle com.ibm.etools.webtools.webedit.common [1.1.0,2.0.0)
Cannot satisfy dependency:
From: jQuery Web Tools 1.0.0.v20121120_2112 (com.ibm.webtools.jquery.feature.feature.group 1.0.0.v20121120_2112)
To: com.ibm.etools.rpe.jquery http://1.0.0.v20121022_1611
Cannot satisfy dependency:
From: IBM jQuery Mobile Tools 5.0.5001.v20121214_1542 (com.ibm.webtools.jquery.tools.feature.feature.group 5.0.5001.v20121214_1542)
To: com.ibm.webtools.jquery.feature.feature.group [1.0.0,2.0.0)
  • IdanAdar
    IdanAdar
    49 Posts
    ACCEPTED ANSWER

    Re: Error in installing Worklight in Eclipse

    ‏2013-01-09T06:12:42Z  in response to SystemAdmin
    kanikabht,

    Can you try this again now with a fresh Eclipse installation, and download IBM Worklight via the Eclipse Marketplace?
    We have recently fixed issues that should enable you to properly install Worklight.

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
  • SystemAdmin
    SystemAdmin
    300 Posts
    ACCEPTED ANSWER

    Re: Error in installing Worklight in Eclipse

    ‏2013-01-09T19:51:03Z  in response to SystemAdmin
    I am receiving essentially the same error messages:

    Cannot complete the install because one or more required items could not be found.
    Software being installed: IBM Worklight Studio 5.0.5001.v20121217_1857 (com.ibm.imp.tools.feature.feature.group 5.0.5001.v20121217_1857)
    Missing requirement: IBM Web Editor Common 1.1.0.v20121012_0113 (com.ibm.etools.webtools.webedit.common 1.1.0.v20121012_0113) requires 'bundle org.eclipse.wst.css.core [1.1.403,2.0.0)' but it could not be found
    Cannot satisfy dependency:
    From: IBM Worklight Studio 5.0.5001.v20121217_1857 (com.ibm.imp.tools.feature.feature.group 5.0.5001.v20121217_1857)
    To: com.ibm.imp.webtools.core.feature.feature.group 1.1.0
    Cannot satisfy dependency:
    From: Web Tools Core 1.1.0.v20121012_0113 (com.ibm.imp.webtools.core.feature.feature.group 1.1.0.v20121012_0113)
    To: com.ibm.etools.webtools.webedit.common http://1.1.0.v20121012_0113

    This was after a fresh installation today of Eclipse for Java EE
    (Eclipse Java EE IDE for Web Developers. Version: Helios Service Release 2. Build id: 20110218-0911) and getting Worklight from the Eclipse Marketplace. Please advise. I am running Windows 7 and Firefox 17.0.1. Thanks.

    Brian
  • IdanAdar
    IdanAdar
    49 Posts
    ACCEPTED ANSWER

    Re: Error in installing Worklight in Eclipse

    ‏2013-01-10T09:17:32Z  in response to SystemAdmin
    Hello Brian,

    We have a defect here it seems. I have opened a customer issue for this.
    Is it a problem to install Eclipse Indigo or Juno in the meanwhile?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
    • SystemAdmin
      SystemAdmin
      300 Posts
      ACCEPTED ANSWER

      Re: Error in installing Worklight in Eclipse

      ‏2013-01-10T19:28:50Z  in response to IdanAdar
      Hi Idan,

      Thanks for your reply. I have successfully installed (and uninstalled) both Juno and Helios, 3.6 and 4.2 on Windows 7 without any problems. The errors occur when I try to install the Worklight plug-in. I've tried both the zip download package as well as the Eclipse Marketplace...frustrating.

      I'd greatly appreciate your assistance resolving this issue.

      Brian
      • browe
        browe
        2 Posts
        ACCEPTED ANSWER

        Re: Error in installing Worklight in Eclipse

        ‏2013-01-11T23:18:13Z  in response to SystemAdmin
        Hi,

        Are you using Java 7? That doesn't work with Helios.
        Please see: https://www.ibm.com/developerworks/mobile/worklight/download/alternatives.html#helios
        • SystemAdmin
          SystemAdmin
          300 Posts
          ACCEPTED ANSWER

          Re: Error in installing Worklight in Eclipse

          ‏2013-01-12T00:36:58Z  in response to browe
          Thanks for the feedback, browe. Unfortunately, I'm traveling and won't have access to my Windows machine until late on Monday. I'll check my Java version then and report back.

          FYI, I'm experiencing very similar error messages on my Mac, running Mountain Lion. Here is my Mac's Java configuration:

          java version "1.6.0_37"
          Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)
          Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

          The Exclipse platform version on the Mac is also Helios, 3.6.2

          Here are the error messages from the Eclipse Marketplace:

          Cannot complete the install because one or more required items could not be found.
          Software being installed: IBM Worklight Studio 5.0.5001.v20121217_1857 (com.ibm.imp.tools.feature.feature.group 5.0.5001.v20121217_1857)
          Missing requirement: IBM Web Editor Common 1.1.0.v20121012_0113 (com.ibm.etools.webtools.webedit.common 1.1.0.v20121012_0113) requires 'bundle org.eclipse.wst.css.core [1.1.403,2.0.0)' but it could not be found
          Cannot satisfy dependency:
          From: Rich Page Editor Base 1.0.200.v20121101_1546 (com.ibm.etools.rpe.feature.feature.group 1.0.200.v20121101_1546)
          To: com.ibm.etools.rpe.html http://1.0.200.v20121019_2352
          Cannot satisfy dependency:
          From: Rich Page Editor - HTML 1.0.200.v20121019_2352 (com.ibm.etools.rpe.html 1.0.200.v20121019_2352)
          To: bundle com.ibm.etools.webtools.webedit.common [1.0.0,2.0.0)
          Cannot satisfy dependency:
          From: IBM Worklight Studio 5.0.5001.v20121217_1857 (com.ibm.imp.tools.feature.feature.group 5.0.5001.v20121217_1857)
          To: com.ibm.etools.rpe.feature.feature.group 1.0.200

          I'd welcome your/others' feedback and suggestions.

          Brian
          • SystemAdmin
            SystemAdmin
            300 Posts
            ACCEPTED ANSWER

            Re: Error in installing Worklight in Eclipse

            ‏2013-01-18T03:55:32Z  in response to SystemAdmin
            Thanks to a post in Oct 2012 by jeffmil, and to the Java version heads-up from browe, I've finally completed a successful install of Worklight V5.0.5 on my Windows 7 ThinkPad. Here's jeffmil's post:

            "Thanks Tom. I did a Check for Updates and there weren't any. But it got me thinking. So I tried Install New Software and selected all sites instead of just the Worklight site that I tried previously. That request failed because evidently my Eclipse repository status was wrong. It told me my request failed because CVS and Mylyn were already installed, and they would be updated in the list of installed components. So I cancelled out of that and tried installing Worklight again. This time there were no missing components and Worklight installed!

            So there is a problem with the list of plugins with the default Indigo JEE installation, at least on some instances of the install. Those apparently missing components are not missing, just not properly registered. Running Install New Software, selecting all repositories, letting it fail and fix itself and then cancelling, will allow Worklight to install succesfully. I see here http://marketplace.eclipse.org/content/ibm-worklight-developer-edition/metrics#.UIUwyJLFtil that others have had similar problems, and most are probably due to Eclipse not registering installed components correctly, not due to Worklight. Maybe a footnote on the dW page would help avoid this. All good now."

            Instead of sticking with Helios and downgrading to Java 6.x, I installed Juno 4.2.1. (eclipse-jee-juno-SR1-win32.zip). I selected "Install New Software" within the Eclipse Help drop-down and selected "All Available Sites" after viewing the content of the "Available Software Sites" preferences link. I had to delete roughly 10 URLs that were invalid, according to Eclipse. I then installed the Marketplace Client which is located within the General Purpose Tools on the Juno update site (http://download.eclipse.org/releases/juno). This was an attempt to invoke the process that jeffmil describes above: to correct Eclipse's apparent registry issues.

            After the MC installed successfully, I returned to the Help drop-down and selected the "Eclipse Marketplace. Using the search term "Worklight" I found the plug-in for the IBM Worklight Developer Edition. Clicking on the Install button initiated the installation, which successfully (and finally!!!) installed.
            • RolandM
              RolandM
              2 Posts
              ACCEPTED ANSWER

              Re: Error in installing Worklight in Eclipse

              ‏2013-01-24T09:28:14Z  in response to SystemAdmin
              Hi Everybody,
              I had the same problem - I could resolve it by just starting eclipse as an Administrator in Windows 7.
              Then I defined the Software Site and it ran through without any problem.

              Best Regards
              Roland M
              • SystemAdmin
                SystemAdmin
                300 Posts
                ACCEPTED ANSWER

                Re: Error in installing Worklight in Eclipse

                ‏2013-01-29T22:43:38Z  in response to RolandM
                Despite my last post, Roland, the "real fix" for me turned out to be what you stated. I launched Eclipse (Juno) as Admin, then went to the Eclipse Marketplace and searched using the "Worklight" term. The install process ran fine and without errors. BTW, no need to run again as Admin to use Eclipse/Worklight.

                Hey IBM Dev Team, another (Windows) documentation update for your consideration!...;-).
                • SystemAdmin
                  SystemAdmin
                  300 Posts
                  ACCEPTED ANSWER

                  Re: Error in installing Worklight in Eclipse

                  ‏2013-01-31T16:19:41Z  in response to SystemAdmin
                  Brian and Roland,

                  So the resolution to the errors posted above is that you need to be administrator to install the Worklight plugin?

                  Barbara Hampson, Manager, IBM Worklight
                  • RolandM
                    RolandM
                    2 Posts
                    ACCEPTED ANSWER

                    Re: Error in installing Worklight in Eclipse

                    ‏2013-01-31T18:38:36Z  in response to SystemAdmin
                    Hi Barbara,

                    yes - it will solve the problem.

                    But it´s not really clear what causes the problem - eclipse or the Worklight plugins .
                    I can say that we also tried to make a "hello world"-plugin - nothing else - for the current RDP 8.5 version and it did not install without starting RDP as administrator.

                    The Web is telling us, it may be an eclipse bug, which should be solved within helios. But the problem with worklight plugins occured within juno(!).
                    This means either the bug returned or in this case it is another problem.

                    However - starting eclipse as administrator solves my problem an afterwards I can work as "normal" user.
                    So far so good.
                    Maybe an IBM Developer can "unravel the mystery"
                    Best Regards
                    Roland M
                  • SystemAdmin
                    SystemAdmin
                    300 Posts
                    ACCEPTED ANSWER

                    Re: Error in installing Worklight in Eclipse

                    ‏2013-01-31T23:06:08Z  in response to SystemAdmin
                    Hi Barbara,

                    Just to add a bit to Roland's good comments...I would include an examination of registry errors/issues with Eclipse (in my case Juno) in your search. From all the posts and error messages that I've read I think that this could be a high-probability source of the Worklight installation issue...my 2 cents.

                    Brian Queen
                    • SystemAdmin
                      SystemAdmin
                      300 Posts
                      ACCEPTED ANSWER

                      Re: Error in installing Worklight in Eclipse

                      ‏2013-02-07T23:54:32Z  in response to SystemAdmin
                      Thanks Brian and Roland. I've taken up the discussion with our development and ID teams to follow up.
                      Also a heads up,

                      Note: IBM forums are in the process of migrating to a new format. During migration the forums will be frozen and in read-only mode. If you wish to continue this thread discussion please post it on stackoverflow, where the Worklight team and others can respond.

                      See the Forum Migration announce post for more details. Thank you.

                      Barbara Hampson, Manager, IBM Worklight