Topic
1 reply Latest Post - ‏2012-12-28T13:10:55Z by KMooney
SystemAdmin
SystemAdmin
5507 Posts
ACCEPTED ANSWER

Pinned topic Issue regarding rpt agent 8.3.0 in unix

‏2012-12-27T18:28:00Z |
hi, i am using linux agent 8.3 version for ruuning the test run,what are the process i have to do.
up to my knowledge,i provided the hostname in majordemo.config file.In unix mdstop.sh i stopped that one,i start the
mdstart.sh ..script.then i restarted the agent ./RASTOP.SH,./RASTART.SH file respectively,if i check in my workbench
it is saying there is no remote agent in this workbench...please help me,itz urgent..........thanks for all
Updated on 2012-12-28T13:10:55Z at 2012-12-28T13:10:55Z by KMooney
  • KMooney
    KMooney
    259 Posts
    ACCEPTED ANSWER

    Re: Issue regarding rpt agent 8.3.0 in unix

    ‏2012-12-28T13:10:55Z  in response to SystemAdmin
    It doesn't hurt to run the RAC via RASTART.SH along with the new Load Generation Agent but it isn't necessary with 8.3.0. All you need to be concerned about is Majordomo (MDStart.sh/MDStop.sh).

    It is important to install the agent as root.

    After executing MDStart.sh verify the Majordomo process is running.

    Make sure whatever hostname is in majordomo.config can be DNS resolved on the agent. From a shell ping exactly what was put into majordomo.config. If the ping doesn't work consider putting the IP address of the workbench in majordomo.config instead.

    The majordomo.config file has an optional debug flag that is set to false by default. Edit the file and set it to true. You do not have to restart the agent. Within about ten seconds it should automatically pick up the changes to majordomo.config. Look in /tmp/root for majordomo.log. In that file will be information about the attempts to contact the workbench including information about any failures and the reason for the failures.

    Consider whether a firewall might be preventing successful contact. Open a telnet session to the workbench at port 7080 (or whatever the workbench port is set to). Type a few characters and press Enter. You should get some kind of response such as HTTP/1.1 400 Bad Request. If you can't connect or don't get this response try disabling firewalls on both ends if only temporarily to verify that is the issue.

    The default port for the workbench is 7080. If it was changed for some reason via Window > Preferences > Test > Server make sure the port number specified there is the same one specified in majordomo.config.