Topic
5 replies Latest Post - ‏2013-01-17T12:24:12Z by Dragos.Cojocari
SystemAdmin
SystemAdmin
1299 Posts
ACCEPTED ANSWER

Pinned topic HTML TEXT in RTC showing without format in RPE

‏2012-12-20T17:44:28Z |
Hi

I have made a document on RPE using data from RTC.
Some fields in the RTC are "Large HTML" or "HTML" so they contain text with a specific format like bold, italic, etc.

When I run my document on the RPE it shows like this :

"<bd>We</bd> will provide <bd>Services</bd> (as defined above) to <bd>You</bd> in support of the <bd>Customer</bd>."
Instead of showing like this :

We will provide Services (as defined above) to You in support of the Customer

Is there a way to convert the plain text into html text or rich text?

PD: In the phorum it looks good, thats why I replace the "" "" with "<bd>" and "</bd>"
Updated on 2013-01-17T12:24:12Z at 2013-01-17T12:24:12Z by Dragos.Cojocari
  • SystemAdmin
    SystemAdmin
    1299 Posts
    ACCEPTED ANSWER

    Re: HTML TEXT in RTC showing without format in RPE

    ‏2012-12-20T17:46:58Z  in response to SystemAdmin
    the <bd> are actually ! But if i post here the correct sentence it will show you the text in bold (thats whatI want in my rpe text).
  • Dragos.Cojocari
    Dragos.Cojocari
    1375 Posts
    ACCEPTED ANSWER

    Re: HTML TEXT in RTC showing without format in RPE

    ‏2012-12-21T13:55:46Z  in response to SystemAdmin
    Hey Cesar,

    AFAIk RTC does not expose rich text though their REST API. You need to raise an RFE for RTC for this. In the meantime you can uses RPE 1.2 new feature, XHTML in JavaScript, to workaround the issue. See the template I provided for this question. While that is for DOORS the idea remains the same, you can use RPE to process the data at a very fine grained level.

    Assuming the RTC text comes like <bd>some text</bd> than the script should look like:

    Edit: script moved in attached file as the forum was rendering it changed.

    The XHTML Input and XHTML Output must be toggled.

    Regards,
    Dragos

    RPE Actual

    Message was edited by: Dragos.Cojocari

    Message was edited by: Dragos.Cojocari

    Attachments

    Updated on 2012-12-21T13:55:46Z at 2012-12-21T13:55:46Z by Dragos.Cojocari
    • SystemAdmin
      SystemAdmin
      1299 Posts
      ACCEPTED ANSWER

      Re: HTML TEXT in RTC showing without format in RPE

      ‏2012-12-21T17:26:12Z  in response to Dragos.Cojocari
      Hi Dragos

      Thanks for your reply.
      I did not understand , can this be done with RPE 1.1.2.2? or just with RPE 1.2?

      I'm trying the script you sent on RPE 1.1.2.2 in the "test script" window but I got :
      Running...
      Error:invalid flag after regular expression (src1#2)Finished

      Please can you explain me detailed?
      • SystemAdmin
        SystemAdmin
        1299 Posts
        ACCEPTED ANSWER

        Re: HTML TEXT in RTC showing without format in RPE

        ‏2012-12-27T17:15:34Z  in response to SystemAdmin
        Hi Dragos:

        I installed the new RPE 1.2 and create a v2 template. I used the functionality for xhtml output.I just clicked the xhtml output box and it did the job.

        But when I upload the template to my RTC 4.0.1 it can not be done, it shows an error.

        I created a v1 template (using rpe 1.2) and it uploaded it fine into RTC 4.0.1
        Does this means that RPE v2 templates are not compatible with RTC 4.0.1?
  • Dragos.Cojocari
    Dragos.Cojocari
    1375 Posts
    ACCEPTED ANSWER

    Re: HTML TEXT in RTC showing without format in RPE

    ‏2013-01-17T12:24:12Z  in response to SystemAdmin
    >>> Does this means that RPE v2 templates are not compatible with RTC 4.0.1?
    Yes. See this for more details: An introduction to RPE 1.2

    Regards,
    Dragos

    RPE Actual