Topic
  • 2 replies
  • Latest Post - ‏2012-12-21T11:03:39Z by SystemAdmin
SystemAdmin
SystemAdmin
554 Posts

Pinned topic opl125.dll not found

‏2012-12-20T10:58:40Z |
Hello There,

I installed ODME 3.7 (which uses opl12.5) and wrote a java code to run an optimization problem. I got the error

Native code library failed to load: ensure the appropriate library (opl125.dll/.so) is in your path.
Exceptions:
opl125 (C:\Program Files\IBM\ILOG\ODME37\Developer\ide\eclipse\dropins\oplide\plugins\ilog.odms.ide.opllang.win32.win32.x86_64_12.5.0.20121031-1709\opl125.dll is not a valid Win32 application. )
opl_lang_wrap_cpp (Not found in java.library.path)
opl_core_wrap_cpp_java125 (Not found in java.library.path)
opl_core_wrap_cpp (Not found in java.library.path)
cp_wrap_cpp_java125 (Not found in java.library.path)
cp_wrap_cpp (Not found in java.library.path)
concert_wrap_cpp_java125 (Not found in java.library.path)
concert_wrap_cpp (Not found in java.library.path)
It might also be related to missing vsrdist runtime DLLs.
Exception in thread "main" java.lang.ExceptionInInitializerError
at java.lang.J9VMInternals.initialize(J9VMInternals.java:222)
at ilog.concert.cppimpl.concert_wrap.setDebugWrappers(concert_wrap.java:34)
at ilog.opl.IloOplFactory.setDebugMode(IloOplFactory.java:152) ...

I included oplall.jar in my build bath. the same thing worked just fine exactly two days ago
Updated on 2012-12-21T11:03:39Z at 2012-12-21T11:03:39Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    554 Posts

    Re: opl125.dll not found

    ‏2012-12-20T12:22:44Z  
    Hello,
    You could try the different suggestions posted in the end of this thread:

    http://www.ibm.com/developerworks/forums/thread.jspa?threadID=455685&tstart=30

    Philippe
  • SystemAdmin
    SystemAdmin
    554 Posts

    Re: opl125.dll not found

    ‏2012-12-21T11:03:39Z  
    Hello,
    You could try the different suggestions posted in the end of this thread:

    http://www.ibm.com/developerworks/forums/thread.jspa?threadID=455685&tstart=30

    Philippe
    That did not help. I am using a windows system (64 bit, but my java is 32 bit). I also tried giving the path to opl125.dll my PATH variable (there are three of those), but that did not help either.