Topic
1 reply Latest Post - ‏2013-01-02T23:01:08Z by SystemAdmin
RS_UK_HAL
RS_UK_HAL
180 Posts
ACCEPTED ANSWER

Pinned topic Manual or AIW install of Common Agent on Win2008 with Citrix XenApp.

‏2012-12-19T10:03:24Z |
I have HS22 with Windows Server 2008 Enterprise Edition R2 SP1 64-bit and the Citrix XenApp 6 installed.

I have IBM Systems Director Server 6.3.2 installed on a separate HS22 blade.

When I try to push the Common Agent out to HS22 with Citrix, the job just sits there at 5% and nothing happens.

If I try to install the Common Agent manually, I get an error message box saying:

"DNZINS0180E: The Windows Remote Desktop Session Host is enabled and will prevent IBM Systems Director Common Agent from installing successfully. Disable the Session Host and run this set-up again."

I'm being told that the Citrix XenApp requires this Windows Remote Desktop Session Host - it's a prerequisite - so it cannot be disabled, unless the whole Citrix 'farm' is broken down.

1. Is there a safe way to temporarily disable the Windows Remote Desktop Session Host, without breaking Citrix?
2. Can I just stop all the Citrix services, then disable Windows Remote Desktop Session Host and then install Common Agent?
3. Has anyone encountered the same situation in their environment?
4. I can't see anything in documentation in relation to this in this forum, InfoCentre or RedBooks. Does anyone have any useful links?
Updated on 2013-01-02T23:01:08Z at 2013-01-02T23:01:08Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    13281 Posts
    ACCEPTED ANSWER

    Re: Manual or AIW install of Common Agent on Win2008 with Citrix XenApp.

    ‏2013-01-02T23:01:08Z  in response to RS_UK_HAL
    It's been a LONG time since I worked with Citrix. Try this:

    Open a Command Prompt as Administrator (i.e. Run As Administrator)
    Within the Command Prompt, run the command 'change user /install'
    Also within the Command Prompt, star the Systems Director Common Agent installation
    After the installation, run the command 'change user /execute'

    BTW... if you're doing this remotely, you need to make sure you are opening your RDP session as and administrator (i.e. 'mstsc.exe /admin').

    ----
    Craig Elliott
    IBM Advanced Technical Skills