Topic
  • 4 replies
  • Latest Post - ‏2012-12-31T11:35:06Z by raanan
elvis_gn
elvis_gn
2 Posts

Pinned topic Worklight 5.0.5 Console not displaying deployed applications

‏2012-12-19T07:16:48Z |
Hi,

I just did a clean installation of Worklight 5.0.5 and tried migrating and creating a new application and deploying it. The deployment of all environments happens successfully but nothing is showing in my Console.

Could it be coz I'm logged in as guest ? I cannot logout also, link does not work.

Regards,
Elvis.
  • AntonAleksandrov
    AntonAleksandrov
    55 Posts

    Re: Worklight 5.0.5 Console not displaying deployed applications

    ‏2012-12-19T15:08:29Z  
    It might be that your browser has cached WL console. Try cleaning the cache and refreshing.
    In case this doesn't help - can you deploy adapter?
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: Worklight 5.0.5 Console not displaying deployed applications

    ‏2012-12-19T19:03:06Z  
    If you have installed worklight server as separate then it gets installed at port 9080 and the worklight studio deploys the app on port 8080. So you can do one thing, copy the .wlapp file from the bin directory of the applicaion after building the app and deploy it on the console of the 9080 port of the worklight server.

    -Dheeraj
  • elvis_gn
    elvis_gn
    2 Posts

    Re: Worklight 5.0.5 Console not displaying deployed applications

    ‏2012-12-30T17:50:08Z  
    If you have installed worklight server as separate then it gets installed at port 9080 and the worklight studio deploys the app on port 8080. So you can do one thing, copy the .wlapp file from the bin directory of the applicaion after building the app and deploy it on the console of the 9080 port of the worklight server.

    -Dheeraj
    Hi Dheeraj,

    How do I do the reverse, i.e change the port to 8080 and get back the auto deployment.

    Thanks,
    Elvis.
  • raanan
    raanan
    50 Posts

    Re: Worklight 5.0.5 Console not displaying deployed applications

    ‏2012-12-31T11:35:06Z  
    • elvis_gn
    • ‏2012-12-30T17:50:08Z
    Hi Dheeraj,

    How do I do the reverse, i.e change the port to 8080 and get back the auto deployment.

    Thanks,
    Elvis.
    Your development environnement is created when you open Eclipse and start a Worklight server for one of your Worklight projects in Eclipse.
    This development environnement you can access through http://localhost:8080/console or http://<YOUR IP>:8080/console
    When you build an application or deploy an adapter in Eclipse it will be reflected in that console (after refresh).
    You can not auto deploy to any other Worklight server.