Topic
  • 3 replies
  • Latest Post - ‏2013-01-16T06:06:44Z by SystemAdmin
SystemAdmin
SystemAdmin
1299 Posts

Pinned topic Product compatibility of RPE template version 2 (RPE 1.2)

‏2012-12-19T05:23:23Z |
Hi,

We were using RRC 3.0.1.3 and RPE 1.1.2.2, and there was no problem. Now we are upgrading to RPE 1.2 (no change in RRC version), and problem occurs when uploading new version of template into RRC and displaying it by RRDG. It is likely that RRC 3.0.1.x cannot read the template which is created in RPE 1.2. There is a significant difference between the Template version 1 and version 2.
http://pic.dhe.ibm.com/infocenter/rpehelp/v1r2/topic/com.ibm.rational.pe.publishing.doc/topics/t_template.html
(The template version you choose must align with the supported template version of the data provider. Verify that your data provider supports version 2 templates before using them.)

According to version compatibility matrix
http://pic.dhe.ibm.com/infocenter/prodguid/v1r0/clarity/softwareReqsForProduct.html

RPE 1.2 supports RRC 3.0.1.x
RRC 3.0.1.x does not support RPE 1.2

We would like to clarify which one is correct, and why there is a gap in the matrix. Thanks
Updated on 2013-01-16T06:06:44Z at 2013-01-16T06:06:44Z by SystemAdmin
  • Dragos.Cojocari
    Dragos.Cojocari
    1647 Posts

    Re: Product compatibility of RPE template version 2 (RPE 1.2)

    ‏2012-12-19T08:17:59Z  
    Hey Kenji,

    That is expected. RPE 1.2 can generate templates with version 1 or 2. If you plan on using those templates with other applications that use RRDG 1.1.2.2 and older such as CLM, DOORS, Rhapsody ( basically all Rational products today) you need to generate version 1 templates.

    For more details see the RPE 1.2 Infocenter and An introduction to RPE 1.2

    Regards,
    Dragos

    RPE Actual
  • SystemAdmin
    SystemAdmin
    1299 Posts

    Re: Product compatibility of RPE template version 2 (RPE 1.2)

    ‏2013-01-07T15:28:06Z  
    Hi,

    Can i ask you how do you download RPE 1.2 ?
    I tried in passport advantagesearch on the IBM site but RPE is not in the list of products.

    Thanks.
    Flog78
  • SystemAdmin
    SystemAdmin
    1299 Posts

    Re: Product compatibility of RPE template version 2 (RPE 1.2)

    ‏2013-01-16T06:06:44Z  
    Hi,

    Can i ask you how do you download RPE 1.2 ?
    I tried in passport advantagesearch on the IBM site but RPE is not in the list of products.

    Thanks.
    Flog78
    Hi,

    You should create a new thread for your download issue. Please try to search following in Passport Advantage:

    IBM Rational Publishing Engine V1.2 Multiplatform Multilingual eAssembly (CRL0IML)
    or
    IBM Rational Publishing Engine V1.2 for Multiplatforms Multilingual (CIEE8ML)

    Find by part number is easier. If you still cannot find it, it might be your entitlement issue. Please contact eCustomerCare to verify your account.
    https://www-112.ibm.com/software/howtobuy/passportadvantage/paocustomer/docs/en_US/ecare.html