Topic
  • 12 replies
  • Latest Post - ‏2013-02-04T14:15:55Z by SystemAdmin
SystemAdmin
SystemAdmin
2327 Posts

Pinned topic An internal error occurred during: "Worklight application builder".

‏2012-12-18T13:22:53Z |
Went through the "Getting Started" documentation and when trying to build the app, I get this error message:


loader constraint violation: when resolving method 
"org.apache.commons.io.FileUtils.iterateFiles(Ljava/io/File;Lorg/apache/commons/io/filefilter/IOFileFilter;Lorg/apache/commons/io/filefilter/IOFileFilter;)Ljava/util/Iterator;" the 

class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/worklight/builder/skins/impl/SkinBuilderImpl, and the 

class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) 

for resolved class, org/apache/commons/io/FileUtils, have different Class objects 

for the type o/filefilter/IOFileFilter;Lorg/apache/commons/io/filefilter/IOFileFilter;)Ljava/util/Iterator; used in the signature



I use the Worklight Developer Edition within Eclipse Juno (Eclipse BUILD id: 20120920-0800, WorklightStudioPlugin 5.0.5.20121129-1027) on top of a Windows 7 Machine.

My local server log output:


[2012-12-18 14:09:32]             Worklight Server started successfully on localhost:8080 [2012-12-18 14:09:32]             Activating Worklight project: HelloWorklightProject... [2012-12-18 14:10:14] FWLSE2001I: Detected more than one IP address. Using 192.168.94.1 as the 

public IP address of the Worklight Server. You can set a different IP address in worklight.properties. [2012-12-18 14:10:15] FWLSE3005I: Application raw reports are disabled. [2012-12-18 14:10:15] FWLST0010I: ====== Started server 

for project HelloWorklightProject-project-customization; Worklight version=5.0.5.20121129-1027-developer-edition [2012-12-18 14:10:15]             Activation done. [2012-12-18 14:10:15]             Starting build process: application 
'HelloWorklight', all environments



What can I do to resolve this problem?
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2012-12-18T13:25:01Z  
    Wow, sorry about that malformed op :-/ seemed like a good idea to use the code tag at the time ...
    Didn't see a way to edit the post ....
  • IdanAdar
    IdanAdar
    741 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2012-12-18T13:45:39Z  
    Fixed.

    This is an upgrade of 5.0.5 on top of 5.0.0.3 correct?
    If so, we have an open defect regarding that. Please try uninstall and reinstalling, or with a fresh Eclipse.

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2012-12-18T14:03:39Z  
    No, this Eclipse installation is fresh and I installed Worklight for the first time, never used it before. The only other plugin currently installed is the Android SDK Plugin, since I do have an Android device and would like to learn about developing for the android platform.

    Android SDK Plugin Build ID: 21.0.0.v201210310015-519525
  • IdanAdar
    IdanAdar
    741 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2012-12-18T14:35:59Z  
    Right, got mixed up with the version numbers.

    I can't say I've seen this...
    Which Java do you have installed? Oracle? IBM?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2012-12-18T14:37:31Z  
    My current java version is Oracle 1.7.0_10 (Build b18)
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2012-12-19T08:25:03Z  
    Interesting. I redownloaded Juno EE and created a separate working environment, installed the Worklight plugin and now it seems to work. I will try now to install the Android Pluging into this new eclipse installation and see whether the error resurfaces.
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2012-12-19T08:34:13Z  
    Very weird, now everything seems to work, with the Android SDK installed. Well, I guess I'll mark this question closed even though I found no real answer, but I do have a working environment now, it seems. =)
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2013-01-03T16:42:42Z  
    I am seeing this same problem having also stepped through the Getting Started documentation. Running Juno Service Release 1, build 20121004-1855 on Windows 7, IBM 7.0 JRE, Worklight 5.0.5.20121217.

    Do you have any insight into the cause of this error or a suggested workaround?
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2013-01-03T19:53:31Z  
    I am seeing this same problem having also stepped through the Getting Started documentation. Running Juno Service Release 1, build 20121004-1855 on Windows 7, IBM 7.0 JRE, Worklight 5.0.5.20121217.

    Do you have any insight into the cause of this error or a suggested workaround?
    I'd like to try to reproduce this but haven't had any luck yet -- sometimes these things can be dependent on ordering -- did you start w/Juno SR 1, or upgrade from non-SR1? Did you install WL first or ADT?
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2013-01-04T09:10:52Z  
    I'd like to try to reproduce this but haven't had any luck yet -- sometimes these things can be dependent on ordering -- did you start w/Juno SR 1, or upgrade from non-SR1? Did you install WL first or ADT?
    I started with Juno SR1, then installed the ADT, then installed WL.

    Let me know if you'd like me to capture anything for diagnostics.
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2013-01-31T08:51:57Z  
    I am now encountering the same issue. I used to be able to run my application without issues, so it does not seem to be installation dependant since I did not update my Eclipse nor Worklight version.
    Worklight: 5.0.5
    Eclipse: 4.2.1

    The only change to my project was that I added a new application to it.
  • SystemAdmin
    SystemAdmin
    2327 Posts

    Re: An internal error occurred during: "Worklight application builder".

    ‏2013-02-04T14:15:55Z  
    I'm having the same problem here.

    My system:
    RHEL 6.3 (OpenClient)
    2.6.32-279.19.1.el6.x86_64
    Eclipse Juno 20120920-0800, JDT freshly unpacked, workspace clean, no additional plugins installed, so no ADT yet
    Worklight 5.0.5 Enterprise
    OpenJDK 1.7.0

    I can proceed as far as creating the Hello World example according to the getting started documentation, but upon running the example I get this output:
    An internal error occurred during: "Worklight application builder". loader constraint violation: when resolving method "org.apache.commons.io.FileUtils.iterateFiles(Ljava/io/File;Lorg/apache/commons/io/filefilter/IOFileFilter;Lorg/apache/commons/io/filefilter/IOFileFilter;)Ljava/util/Iterator;" the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) of the current class, com/worklight/builder/skins/impl/SkinBuilderImpl, and the class loader (instance of org/eclipse/osgi/internal/baseadaptor/DefaultClassLoader) for resolved class, org/apache/commons/io/FileUtils, have different Class objects for the type o/filefilter/IOFileFilter;Lorg/apache/commons/io/filefilter/IOFileFilter;)Ljava/util/Iterator; used in the signature

    Jetty server did run though, I can see an admin page, but no app deployed.

    I switched JRE to IBM 1.7.0 with update-alternatives --config java, Eclipse fails to start, splash screen freezes while loading com.worklight.studio.plugin. After switching back, Eclipse still doesn't start.

    Halp plz!