Topic
  • 2 replies
  • Latest Post - ‏2012-12-15T06:40:57Z by SystemAdmin
SystemAdmin
SystemAdmin
6184 Posts

Pinned topic Padding On or Off Dynamically in WTX

‏2012-12-14T16:00:10Z |
Hi,

I have a scenario where a group in the input xml file may come empty in some cases. In that case the group has to go empty(it should not consume any spaces) in the output file. The group has both text and numeric fields and padding is applied to each each of the fields in the type tree. I have rules for each of the fields where I set the field as "NONE" in case the condition does not match. But the problem I am facing is that the padding of zeros and spaces are applied even though I set field value as "NONE". Is there any way to make the padding dynamically on or off on the rule itself.
Any advise is highly appreciated.

Thanks,
Tridip K Sarma
Updated on 2012-12-15T06:40:57Z at 2012-12-15T06:40:57Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    6184 Posts

    Re: Padding On or Off Dynamically in WTX

    ‏2012-12-14T16:50:41Z  
    Are the elements defined as optional in your output tree? That is, is their range in Properties set to 0:1 or 0:s?

    Is your output file a delimited flat file? Normally, XML data isn't padded.
  • SystemAdmin
    SystemAdmin
    6184 Posts

    Re: Padding On or Off Dynamically in WTX

    ‏2012-12-15T06:40:57Z  
    Are the elements defined as optional in your output tree? That is, is their range in Properties set to 0:1 or 0:s?

    Is your output file a delimited flat file? Normally, XML data isn't padded.
    Thanks Jim!

    I did not set the range(0:1) - after setting the range , it works fine.

    The output is in a flat file format.

    Tridip K Sarma