Topic
6 replies Latest Post - ‏2012-12-19T15:02:51Z by SystemAdmin
SystemAdmin
SystemAdmin
6907 Posts
ACCEPTED ANSWER

Pinned topic Part of .profile not loading.

‏2012-12-12T19:28:28Z |
I am running into an issue. When my user logs in the last step of the .profile will not run. If I run the command . ~/.profile it will finish like it should. Anything i can look for that might cause this issue?
Updated on 2012-12-19T15:02:51Z at 2012-12-19T15:02:51Z by SystemAdmin
  • ostost
    ostost
    68 Posts
    ACCEPTED ANSWER

    Re: Part of .profile not loading.

    ‏2012-12-12T19:40:42Z  in response to SystemAdmin
    What is the content of the .profile?
    • SystemAdmin
      SystemAdmin
      6907 Posts
      ACCEPTED ANSWER

      Re: Part of .profile not loading.

      ‏2012-12-12T19:54:13Z  in response to ostost
      Here it is:
      PATH=/usr/bin:/etc:/usr/sbin:/usr/ucb:$HOME/bin:/usr/bin/X11:/sbin:..:/u03/app/DW45/app/bin:/u03/app/DW45/app/scripts::/u03/app/DW45/app/batch:/usr/local/dw45/scripts:/usr/bin:/etc:/usr/sbin:/usr/ucb:/me/dwadmin/bin:/usr/bin/X11:/sbin:.:/usr/java5/bin:/usr/java5/bin/:/u01/app/oracle/10g/bin://u01/app/oracle/10g/bin:/usr/local/dw45/java/fop-0.95:/u03/app/DW45/app/xport/scripts:/usr/java5/bin:/usr/lib:/opt/steno/bin:/u01/app/oracle/10g/bin:/usr/local/bin

      export PATH

      if # This is at Shell startup. In normal
      then echo "$MAILMSG" # operation, the Shell checks
      fi # periodically.
      export PATH=$PATH:/usr/java5/bin/:/u01/app/oracle/10g/bin
      export JAVA_HOME=/usr/java5
      export ORACLE_SID=DGWT
      export ORACLE_HOME=/u01/app/oracle/10g
      export PATH=$PATH:/$ORACLE_HOME/bin
      export ORACLE_BASE=/u01/app/oracle
      export DISPLAY=cougar106:2
      . /u01/app/oracle/10g/bin/oraenv
      1. Initialize the DegreeWorks environment
      . /u03/app/DW45/app/scripts/dwenv /u03/app/DW45/dwenv.config
      The last line is the one that will not launch at login.
      • SystemAdmin
        SystemAdmin
        6907 Posts
        ACCEPTED ANSWER

        Re: Part of .profile not loading.

        ‏2012-12-12T19:55:13Z  in response to SystemAdmin
        The last part should be

        . /u01/app/oracle/10g/bin/oraenv
        1. Initialize the DegreeWorks environment
        . /u03/app/DW45/app/scripts/dwenv /u03/app/DW45/dwenv.config
        • SystemAdmin
          SystemAdmin
          6907 Posts
          ACCEPTED ANSWER

          Re: Part of .profile not loading.

          ‏2012-12-12T19:55:53Z  in response to SystemAdmin
          hmm okay the 1. is actually a pound sign to rem the line out.
  • Tibor_B
    Tibor_B
    41 Posts
    ACCEPTED ANSWER

    Re: Part of .profile not loading.

    ‏2012-12-19T12:39:46Z  in response to SystemAdmin
    There are two basic scenarios:

    1. .profile launches sourcing from that file and sourcing fails
    2. .profile fails to launch the sourcing or even terminates beforehand

    I would put some "echo blabla" in profile to find out - may be at the very end of profile. Alternatively you can put some echo into sourced file....
  • SystemAdmin
    SystemAdmin
    6907 Posts
    ACCEPTED ANSWER

    Re: Part of .profile not loading.

    ‏2012-12-19T15:02:51Z  in response to SystemAdmin
    I found that it was failing when it tried to load the .oraenv section. I removed that section and it is working again. Thanks' to everyone that helped me figure this out.