Topic
No replies
SystemAdmin
SystemAdmin
1009 Posts
ACCEPTED ANSWER

Pinned topic WSDL Error

‏2012-12-12T15:19:12Z |
I'm new to webservice,

I copied a wsdl and xsd file into the DP appliance local:///, and uploaded the wsdl into the web server proxy I have created, but the wsdl is giving me fatal error at local:///name.v3.1.wsdl:199:invalid WS-Policy element and message error of 0x80a002a0.

Could someone gave an idea on how to go about resolving this error.

Here is the begining part of the wsdl the error emphasized.

<?xml version="1.0" encoding="UTF-8"?>
<!-- BETAppleBean Schema Version 3.1.0 -->
<xs:schema xmlns="http://name.com/bee/beta/betaRequestResponse-199908.v10.ws" xmlns:beta="http:// name.com/bee/beta/betaRequestResponse-199908.v10.ws" xmlns:xs="http://www.w3.org/2001/XMLSchema" targetNamespace="http:// name.com/bee/beta/betaRequestResponse-199908.v10.ws" elementFormDefault="unqualified" attributeFormDefault="unqualified" version="1.1">
<xs:element name="BETAppleBean" type="LET_BETAAppleBeanExtension"/>

And below is the beginning part of the xsd file

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:tm="http://microsoft.com/wsdl/mime/textMatching/" xmlns:s="http://www.w3.org/2001/XMLSchema" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:BETA="http:// " xmlns:http="http://schemas.xmlsoap.org/wsdl/http/" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/" xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/" xmlns:policy="http://schemas.xmlsoap.org/ws/2004/09/policy" targetNamespace="http://nmae.com/bee/beta/betaRequestResponse-199908.v10.ws">
<wsdl:types>
<s:schema elementFormDefault="qualified" targetNamespace="http://name.com/beta/gst/beeRequestResponse-199908.v10.ws">
<s:include schemaLocation="BETAppleBean_v3_2_0.xsd"/>