Topic
3 replies Latest Post - ‏2013-01-22T12:30:08Z by lowrey
SystemAdmin
SystemAdmin
8523 Posts
ACCEPTED ANSWER

Pinned topic MQ Explorer - MQSC plugin error

‏2012-12-11T14:33:09Z |
I am using MQ Explorer 7.5 with MQSC plugin from support pack MS0S (7-1.2.0).

The problem is that MQ Explorer is throwing the following error when trying to expand the MQSC files list from "Navigator" pane:
"An error has occurred. See error log for more details.
com/ibm/mq/explorer/ui/internal/views/MQNavigatorView.getTreeViewer()Lorg/eclipse/jface/viewers/TreeViewer;"

The list is not being expanded. I can't import the files again, because they are already there.
How to fix this problem?
Updated on 2013-01-22T12:30:08Z at 2013-01-22T12:30:08Z by lowrey
  • SystemAdmin
    SystemAdmin
    8523 Posts
    ACCEPTED ANSWER

    Re: MQ Explorer - MQSC plugin error

    ‏2013-01-07T14:45:54Z  in response to SystemAdmin
    It might be worth submitting a question to the author via the SupportPac MS0S page. In case they don't monitor this forum.

    Cheers
    Morag
    • lowrey
      lowrey
      4 Posts
      ACCEPTED ANSWER

      Re: MQ Explorer - MQSC plugin error

      ‏2013-01-07T16:24:04Z  in response to SystemAdmin
      MS0S currently does not support MQ v7.5 - either explorer or the MQSC syntax for MQ 7.5.

      I am significantly behind in updating it, due to time constraints and significant changes to the underlying eclipse infrastructure of MQ Explorer and because there's no formal machine consumable definition of the MQSC language.

      I have a release that supports MQ v7.1 syntax, and will run in both 7.1 and 7.5 explorer that I am in process of releasing - I am hopeful to ship it within January.

      I am also working on MQ v7.5 support which I plan to ship before mid year. Planning is not promising or guaranteeing.

      And, no, I do not generally monitor this forum. Please direct all correspondence about MS0S and MA7K per the documentation that comes with these supportPacs.

      -Jeff Lowrey
  • lowrey
    lowrey
    4 Posts
    ACCEPTED ANSWER

    Re: MQ Explorer - MQSC plugin error

    ‏2013-01-22T12:30:08Z  in response to SystemAdmin
    Just an update.

    MS0S 1.5 which supports MQ 7.1 Explorer and MQ 7.1 MQSC sytnax is now available.

    http://www-01.ibm.com/support/docview.wss?uid=swg24016826

    It will also run in MQExplorer 7.5, but does not support any MQ 7.5 features or MQSC syntax.