Topic
No replies
SystemAdmin
SystemAdmin
47293 Posts
ACCEPTED ANSWER

Pinned topic Chaing File permissions once for all after Clearfsimport.

‏2012-12-11T09:56:35Z |
Hi,

I have two replicas Replicas - Replcia1 in one region and Relica2 in other region.

1) In "Replica1" I did clearfsimport with umask as 0022.
2) After that I executed the command "cleartool protect –chmod –R 775" in "Replica1" as the assigned
Group should be given read, write, execute permissions.
3) This protection change of -r-xr-xr-x was visible in "Replica1" only.(replica property is set to "Non-preserving").
4) To over come this I run cleartool protect –chmod –R 775 in "Replica2".
5) Then I could see the file permissions as -r-xr-xr-x in both the replicas
6) In Replica2 I run the clearfsimport for the next import with umask set properly to 0002
7) Now the problem is that in Replica2 permissions changed back to -r--r--r-- from -r-xr-xr-x where
as in Replica1 it looks fine -r-xr-xr-x.

Is this an expected behaviour?
How to get this permission issue resolved permanently for subsequent imports?

If I have any chekcouts in Replica2 and try to do reqmaster in Replica2 I get error message saying
"some checkouts in Replica1 are blocking the reqest mastership".
Surprisingly I can see the Replica2 checkouts in Replica1 without using -areplica option.
but I don't have any chekcouts in Replica1.(This forces me to undo chekckout of all in Replica2 and then do remaster in Replica2)

Thank you