Topic
  • 2 replies
  • Latest Post - ‏2012-12-08T01:07:48Z by SystemAdmin
Arnab_Ghosh
Arnab_Ghosh
94 Posts

Pinned topic Throttling not working properly

‏2012-12-07T17:59:04Z |
I have set a throttling limit of 20tps as below:

SLM action - Throttle
Threshold Interval Length - 1
Threshold Interval Type - Fixed
Threshold Algorithm - Greater than
Threshold Type - Count All
Threshold Level - 20
High-Low Release Level - 0
Burst Limit - 0
Reporting Aggregation Interval - 0

But with LoadRunner or SOAPUim, when i am setting a TPS rate of 18tps, throttling starts to happen. Why is it behaving like this? What is the fix for this?
Updated on 2012-12-08T01:07:48Z at 2012-12-08T01:07:48Z by SystemAdmin
  • kenhygh
    kenhygh
    1607 Posts

    Re: Throttling not working properly

    ‏2012-12-07T19:43:23Z  
    Arnab,
    It's been my experience that DP just doesn't do well with an interval length of one second. I've gotten pretty good success with 5 second intervals.

    Ken
  • SystemAdmin
    SystemAdmin
    6772 Posts

    Re: Throttling not working properly

    ‏2012-12-08T01:07:48Z  
    It always worked for me, only catch was in order to get 1 tps I had to specify the threshold ie required minus one. Even concurrency worked fine as well for me. What is the firmware level? I would try 5 TPS ie 4 as threshold then gradually increase it to 20 to see identify the pattern.
    Hope that helps.