Topic
  • 10 replies
  • Latest Post - ‏2012-12-12T14:41:27Z by SystemAdmin
SystemAdmin
SystemAdmin
300 Posts

Pinned topic Worklight v5.0.0.3 Installation on Windows Issue

‏2012-12-06T09:40:10Z |
Hi,

I am facing a weird issue first time. Even though i have installed Worklight many times on different machines in office.

This time am sitting at client side and initially trying to install Developer Edition (free one). It installs successfully and also shows in the Plugins list but it is NOT showing/enabling Worklight options/menus.

I tried on Indigo R 2, Indigo R 1, Classic 7.3.2 but all has same issue.

I tried installing from IBM site and Market place, but in both cases same issue.

I copied someone else's Eclipse which has Worklight already installed in it but when i ran that eclipse again same issue.

I tried by running eclipse with '-clean' option but no luck.

I am using Windows 7 , 32-bit

any idea ? or settings i have to done.

Thanks
Abdul Ahad
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-06T09:42:56Z  
    I have read these two threads but are not helping me out.

    http://www.ibm.com/developerworks/forums/thread.jspa?threadID=449018&tstart=15

    http://www.ibm.com/developerworks/forums/thread.jspa?threadID=447716&tstart=15

    thanks
  • brock_smith
    brock_smith
    5 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-06T13:41:14Z  
    Hi,

    try to download eclipse from here
    1)http://www.eclipse.org/downloads/packages/release/indigo/sr2
    2)To install ADT in Eclipse, click Help Install New Software
    worklight 5.0.3 plugin http://public.dhe.ibm.com/ibmdl/export/pub/software/mobile-solutions/worklight/wdeupdate/
    u will see the worklight project option in menubar!

    Regards,
    Brock--
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-06T14:20:54Z  
    Have you installed any other plugins besides Worklight? This problem almost always indicates a conflict with another plugin that prevents the Worklight plugin from starting. Can you redownload eclipse and start with a fresh workspace and try installing Worklight as the first thing? Also, try using the JEE version of Eclipse rather than Classic.
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-09T10:27:41Z  
    Have you installed any other plugins besides Worklight? This problem almost always indicates a conflict with another plugin that prevents the Worklight plugin from starting. Can you redownload eclipse and start with a fresh workspace and try installing Worklight as the first thing? Also, try using the JEE version of Eclipse rather than Classic.
    Yes I tried the same URL but same issue.

    NellG,
    There is NO plugin i installed, I simply download Eclipse and then install worklight. I tried both options of installing, IBm and Market place, but same issue

    I have tried all supported Eclipse versions ( Classic, JEE, Indigo R1, Indigo 2).

    Plus i always tries with fresh workspace.
    Today i tried installing Worklight 5.0.5 but same issue.....
    any other idea?

    Thanks
    Abdul Ahad
  • IdanAdar
    IdanAdar
    49 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-09T10:34:44Z  
    Hi,

    I have taken Eclipse Juno SR2 and installed Worklight (5.0.5) via the Eclipse Marketplace.
    This passed successfully.

    There seems to be an issue when upgrading 5.0.0.3 to 5.0.5 via the marketplace, but fresh installation works.
    Can you please elaborate on the steps you have taken?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-10T07:37:35Z  
    • IdanAdar
    • ‏2012-12-09T10:34:06Z
    Hi,

    I have taken Eclipse Juno SR2 and installed Worklight (5.0.5) via the Eclipse Marketplace.
    This passed successfully.

    There seems to be an issue when upgrading 5.0.0.3 to 5.0.5 via the marketplace, but fresh installation works.
    Can you please elaborate on the steps you have taken?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
    Hi,

    I have not seen Juno SR2, may be you are talking about Indigo R2.

    I am NOT updated from one version to another.

    Well, I have tried Indigo R1 ,Indigo R2 and Classic .... all fresh downloads.

    I just download then directly went on installing worklight, have tried both options, IBM & Market place.

    So every time there was a fresh Eclipse and no extra plugins.

    But every time same issue

    FYI, this client has applied very strong security policies on networks and PCs. may be it is causing.

    Another person in the Office, he has same Windows 7 32 bit and its working fine on his PC. I copied that Eclipse on my machine and ran it but again same issue. But when I copied it on another Windows XP machine it worked fine.

    anyway, this is not clear why and what is causing this issue.

    I also tried v5.0.5 but same issue. Right now am testing it with June R1, lets see...
    Thanks
    Abdul Ahad
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-10T07:51:09Z  
    Hi,

    I have not seen Juno SR2, may be you are talking about Indigo R2.

    I am NOT updated from one version to another.

    Well, I have tried Indigo R1 ,Indigo R2 and Classic .... all fresh downloads.

    I just download then directly went on installing worklight, have tried both options, IBM & Market place.

    So every time there was a fresh Eclipse and no extra plugins.

    But every time same issue

    FYI, this client has applied very strong security policies on networks and PCs. may be it is causing.

    Another person in the Office, he has same Windows 7 32 bit and its working fine on his PC. I copied that Eclipse on my machine and ran it but again same issue. But when I copied it on another Windows XP machine it worked fine.

    anyway, this is not clear why and what is causing this issue.

    I also tried v5.0.5 but same issue. Right now am testing it with June R1, lets see...
    Thanks
    Abdul Ahad
    BTW, one thing i noticed.

    when i install from IBM or Marketplace then inside the Eclipse folder, the Plugins & Features folder contain LESS number of files as compared to manual zip file download from IBM (iws-update-site-wde.5.0.5.zip).

    the iws-update-site-wde.5.0.5.zip file contains more file but online installation brings less files.
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-10T07:51:48Z  
    BTW, one thing i noticed.

    when i install from IBM or Marketplace then inside the Eclipse folder, the Plugins & Features folder contain LESS number of files as compared to manual zip file download from IBM (iws-update-site-wde.5.0.5.zip).

    the iws-update-site-wde.5.0.5.zip file contains more file but online installation brings less files.
    Manual installation process doesn't work either :)
  • IdanAdar
    IdanAdar
    49 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-10T09:01:42Z  
    Another person in the Office, he has same Windows 7 32 bit and its working fine on his PC. I copied that Eclipse on my machine and ran it but again same issue. But when I copied it on another Windows XP machine it worked fine.
    You say you have copied an Eclipse folder from your co-worker that has Worklight installed - for him it works and on your machine it doesn't? This does not seem to be a Worklight issue then...?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
  • SystemAdmin
    SystemAdmin
    300 Posts

    Re: Worklight v5.0.0.3 Installation on Windows Issue

    ‏2012-12-12T14:41:27Z  
    • IdanAdar
    • ‏2012-12-10T09:01:42Z
    Another person in the Office, he has same Windows 7 32 bit and its working fine on his PC. I copied that Eclipse on my machine and ran it but again same issue. But when I copied it on another Windows XP machine it worked fine.
    You say you have copied an Eclipse folder from your co-worker that has Worklight installed - for him it works and on your machine it doesn't? This does not seem to be a Worklight issue then...?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
    this is resolved now.

    Actually there was an application on the machine and was using very old version of JDK so when Eclipse was installing Plugins and unpacking them after download, it finds some unsupported classes so it breaks out.....this is my guess.

    Even though environment variable was set with JDK 7 but this older JDK was set with strange name that's why it was not looking like JDK.

    I traced all PATH variables and in this way i reached to it and removed it, then it worked fine.

    Thanks
    Abdul Ahad