Topic
22 replies Latest Post - ‏2012-12-11T23:03:12Z by wnm3
sun1431
sun1431
16 Posts
ACCEPTED ANSWER

Pinned topic Validation of html and is hanging in Eclipse(Juno)

‏2012-12-05T04:17:41Z |
Hi Guys,
I have installed Eclipse-Juno and started developing a Web-app using dojo1.8 and WebSphere8.5 full profile.
Now since couple of days I am having this validation issue(HTML Syntax and Dojo tooling ) and due to that project doesn't get published.
I have attached the file describing exact validation.

Can someone please help?

Thank you
Manish
  • SystemAdmin
    SystemAdmin
    590 Posts
    ACCEPTED ANSWER

    Re: Validation of html and is hanging in Eclipse(Juno)

    ‏2012-12-05T21:08:47Z  in response to sun1431
    Hi Manish,

    Is the problem that the progress on these jobs never completes, thus blocking publishing? What were the actions that led up to this point (e.g., changing JavaScript source)?
  • SystemAdmin
    SystemAdmin
    590 Posts
    ACCEPTED ANSWER

    Re: Validation of html and is hanging in Eclipse(Juno)

    ‏2012-12-05T21:14:11Z  in response to sun1431
    Also, without knowing specifically why these jobs may be hung, does disabling the HTML Validator allow you to publish again? The HTML Validator can be disabled through the preferences. Under Validation, look for the HTML Syntax Validator, and uncheck both its Manual and Build checkboxes, and click OK.
  • sun1431
    sun1431
    16 Posts
    ACCEPTED ANSWER

    Re: Validation of html and is hanging in Eclipse(Juno)

    ‏2012-12-06T19:02:59Z  in response to sun1431
    Some time it just triggers with no action. Some time when I start/open Juno as just now I started the Juno and as it opens the window and loaded the project I see it started HTML validation and will stay at 0% (in progress bar) and I also see Error too .

    Please check attached for more detail about error.

    I will try to turn of the validation and see if it helps
    Thank you
    Manish
    • SystemAdmin
      SystemAdmin
      590 Posts
      ACCEPTED ANSWER

      Re: Validation of html and is hanging in Eclipse(Juno)

      ‏2012-12-06T21:49:40Z  in response to sun1431
      Hi Manish,

      Those errors look pretty interesting. Could you paste the stack trace from them?

      Thanks
      • sun1431
        sun1431
        16 Posts
        ACCEPTED ANSWER

        Re: Validation of html and is hanging in Eclipse(Juno)

        ‏2012-12-06T22:02:29Z  in response to SystemAdmin
        Again as I open a jsp file. JSP content validation starts and is hanging since very long at 0%. Also Dojo tooling analyzing resource change is also handing.
        And now I guess I cannot publish.

        here are the exception in attached file.

        Attachments

        • SystemAdmin
          SystemAdmin
          590 Posts
          ACCEPTED ANSWER

          Re: Validation of html and is hanging in Eclipse(Juno)

          ‏2012-12-06T22:10:56Z  in response to sun1431
          The errors from this error log file you've attached are older. If you double click on the error in the Error Log view, it should give you the full Exception stack trace. Since it looks pretty repetitive, you can just paste one of them here.
          • sun1431
            sun1431
            16 Posts
            ACCEPTED ANSWER

            Re: Validation of html and is hanging in Eclipse(Juno)

            ‏2012-12-06T22:46:56Z  in response to SystemAdmin
            Here are the exception file
          • sun1431
            sun1431
            16 Posts
            ACCEPTED ANSWER

            Re: Validation of html and is hanging in Eclipse(Juno)

            ‏2012-12-06T22:48:06Z  in response to SystemAdmin
            one more error image
            • SystemAdmin
              SystemAdmin
              590 Posts
              ACCEPTED ANSWER

              Re: Validation of html and is hanging in Eclipse(Juno)

              ‏2012-12-11T20:03:35Z  in response to sun1431
              Do the error messages from error2.bmp cease once you open the Dojo preference page?
              • sun1431
                sun1431
                16 Posts
                ACCEPTED ANSWER

                Re: Validation of html and is hanging in Eclipse(Juno)

                ‏2012-12-11T20:34:09Z  in response to SystemAdmin
                I don't think so.
                I am just waiting for 4.2.2 update to see if problem is solved.
              • wnm3
                wnm3
                9 Posts
                ACCEPTED ANSWER

                Re: Validation of html and is hanging in Eclipse(Juno)

                ‏2012-12-11T23:03:12Z  in response to SystemAdmin
                I just waited for the spew to end, then deleted the error log and closed and restarted Eclipse. The second time all is fine (likely because I use -clean for all my starts). I have checked the Dojo properties page and the pointers for Dojo are correct.

                Note: It would be nice if one could edit these Dojo paths without the UI wanting to recopy all the content from another location into the project. My set up is to have a Dojo181 project where dojo is installed and from which I can create an EAR to deploy in WAS v8.5 and then my application project references the Dojo181 project. I've had to turn off all validation and include the Dojo181/WebContent in the exclude lists for HTML, Javascript, JSP... but somehow the IDE still wants to check this project every once in a while.
      • melickm
        melickm
        3 Posts
        ACCEPTED ANSWER

        Re: Validation of html and is hanging in Eclipse(Juno)

        ‏2012-12-06T22:10:04Z  in response to SystemAdmin
        In addition to the stack trace for the errors that Nick (nsandonat) is asking for above can you please provide some additional information for the hangs.

        1) When the hang happens, can you collect a series of core dumps (3-5) approximately 30s apart by using one of the processes outlined in this technote: http://www-01.ibm.com/support/docview.wss?uid=swg21391829 Note: approach #2 will not work on a 64bit win OS. And approach #3 is not available in WDT.

        2) Can you look at the CPU usage when the hang occurs. In windows you can do this by opening the task manager, and finding the java or eclipse process and look at the CPU column. Can you also provide the #of cores on your machine. This will help us determine if it's a deadlock, and infinite loop or just a long process.
        • sun1431
          sun1431
          16 Posts
          ACCEPTED ANSWER

          Re: Validation of html and is hanging in Eclipse(Juno)

          ‏2012-12-06T22:47:28Z  in response to melickm
          I am using Juno and when I open the eclipse.ini I did not see javaw.
          • wnm3
            wnm3
            9 Posts
            ACCEPTED ANSWER

            Re: Validation of html and is hanging in Eclipse(Juno)

            ‏2012-12-07T20:05:55Z  in response to sun1431
            I'm not sure if this is related to what you are seeing, but in my case, while just moving around in an html file in the editor can sometimes send juno into a non-responsive mode. I'd begun starting eclipse with a console window so I could see if exceptions were being thrown, and found that after refactoring a file name, the old file name was reported as not found by some asynchronous process. I'm not sure if this is the cause for the non-responsive IDE (have to kill the process and restart). I've attached a stack trace of what I saw.

            IIRC, starting eclipse with the console window is done using the eclipse.ini setting:
            -vm
            C:/jdk1.6/bin/java.exe

            (e.g., pointing at the java.exe launches a visible window)
            • wnm3
              wnm3
              9 Posts
              ACCEPTED ANSWER

              Re: Validation of html and is hanging in Eclipse(Juno)

              ‏2012-12-07T21:14:03Z  in response to wnm3
              It seems the more important messages may be the ones like this:
              IMPLEMENT resolveForAllocation for class org.eclipse.wst.jsdt.internal.compiler.ast.ConditionalExpression
              org.eclipse.jst.j2ee.internal.deployables.JEEFlattenParticipantProvider
              IMPLEMENT resolveForAllocation for class org.eclipse.wst.jsdt.internal.compiler.ast.ConditionalExpression

              as there were several bugs in Eclipse reporting this type of problem, but were thought to have been fixed a few years ago (e.g., https://bugs.eclipse.org/bugs/show_bug.cgi?id=325238 and trace back to all the duplicates). I wonder if one fix slipped through the cracks.
              • wnm3
                wnm3
                9 Posts
                ACCEPTED ANSWER

                Re: Validation of html and is hanging in Eclipse(Juno)

                ‏2012-12-07T21:24:52Z  in response to wnm3
                Here is a javacore created via Ctrl+Break when the IDE has become non-responsive.
                • sun1431
                  sun1431
                  16 Posts
                  ACCEPTED ANSWER

                  Re: Validation of html and is hanging in Eclipse(Juno)

                  ‏2012-12-07T21:40:36Z  in response to wnm3
                  I also have seen this behaviour some times that if I open say a jsp by just double clicking on the file, the whole Esclipse become un-responsive, but if I open that jsp via selecting "Open With" -> "JSp Editer" then it doesn't have problem.
                  • wnm3
                    wnm3
                    9 Posts
                    ACCEPTED ANSWER

                    Re: Validation of html and is hanging in Eclipse(Juno)

                    ‏2012-12-07T21:51:46Z  in response to sun1431
                    Yes -- I've tried to stop using the Rich Text Editor in favor of the more simple HTML Editor to avoid problems like this. I also found it useful to have the Rich Text Editor default to opening in Source mode (a setting in the properties). -- I'm afraid I've degraded to pure speculation and apologize if I've hijacked your original thread.
                  • melickm
                    melickm
                    3 Posts
                    ACCEPTED ANSWER

                    Re: Validation of html and is hanging in Eclipse(Juno)

                    ‏2012-12-08T00:24:30Z  in response to sun1431
                    @sun1431 For the original issue: As mentioned above, you can get the console window by adding the -vm argument and pointing to the java.exe executable directly in your eclipse.ini as shown in the example below. If you provide the requested stack traces, I'll take a look.

                    -vm
                    C:/jdk1.6/bin/java.exe

                    @wnm3, I didn't get a chance to look too closely at your stack trace and other info, but there are a number of known performance related bugs on Juno. There are a few of these such as https://bugs.eclipse.org/bugs/show_bug.cgi?id=391626 that are specifically related to editing, and you might be hitting one of those. The good news is that a number of these are already released into the upcoming 4.2.2 codestream.

                    If you don't think one of the existing bugs is your issue, would you kindly start a separate thread, as to keep things clearer?

                    thanks,
                    mike.
                    • wnm3
                      wnm3
                      9 Posts
                      ACCEPTED ANSWER

                      Re: Validation of html and is hanging in Eclipse(Juno)

                      ‏2012-12-08T16:25:28Z  in response to melickm
                      Thanks Mike -- I think the bug you referenced could easily be one I've tripped over. If 4.2.2 is accessible soon, or the recent builds are relatively stabled I'm happy to try using one of them (e.g., the 12/05/12 build?). If I have the chance to capture some javacore's during a hang, I'll create a new forum entry as requested.
                      • melickm
                        melickm
                        3 Posts
                        ACCEPTED ANSWER

                        Re: Validation of html and is hanging in Eclipse(Juno)

                        ‏2012-12-10T14:26:51Z  in response to wnm3
                        @wnm3 They have posted a patch with fixes for a number of the SR1 performance issues they were having. If you're interested in giving it a try see this comment: https://bugs.eclipse.org/bugs/show_bug.cgi?id=385272#c212. Note: Full disclosure. I think a fix for the editing is in there, but I'm not 100% certain (didn't check). You could also try a development build of 4.2.2. which would include the fixes.