Topic
4 replies Latest Post - ‏2012-12-06T19:48:40Z by Apcheung
Apcheung
Apcheung
7 Posts
ACCEPTED ANSWER

Pinned topic Get Time out error EGL2153E when running EGL/Java on WebSphere on zOS

‏2012-12-05T00:43:08Z |
Running RBD : 8.0.1.3 and WAS v7 on zOS.

Our user requirments for timeout is eight (8) hours. For testing purpose, I have setup "no time-out" on the server level, application level and module level in WAS v.7 on zOS. However when I let my application web page sitting still for 40 mins, it gave me an EGL error - EGL2153E.

Explanation of the message: A timeout occurred because of inactivity during a web transaction converse.

I would like to know is there a timeout parameter we can set in EGL or RBD. If not, I would like to know how EGL keep track of how long the web transaction has been inactivity during transaction converse?

Thanks.

Andy Cheung
Updated on 2012-12-06T19:48:40Z at 2012-12-06T19:48:40Z by Apcheung
  • markevans
    markevans
    2743 Posts
    ACCEPTED ANSWER

    Re: Get Time out error EGL2153E when running EGL/Java on WebSphere on zOS

    ‏2012-12-05T13:23:00Z  in response to Apcheung
    Andy,

    I will check some more, but I am not aware of any specific timeout settings in EGL itself.

    That message is usually sent out when either
    a.) the WAS Session timeout was reached
    b.) The Web Server timeout was reached

    If you have a HTTP server or a WAS Web Server plugin...check its setting as well to make sure it is set to a long timeout value as well.
  • Apcheung
    Apcheung
    7 Posts
    ACCEPTED ANSWER

    Re: Get Time out error EGL2153E when running EGL/Java on WebSphere on zOS

    ‏2012-12-05T20:49:11Z  in response to Apcheung
    Thanks Mark for your answer.

    I found this article from WebSphere support site: http://www-01.ibm.com/support/docview.wss?uid=swg21163875

    Please look at item 5), I wonder does setMaxInactiveInterval() method use on HttpSession Object in the IBM UIGateway program?
    • markevans
      markevans
      2743 Posts
      ACCEPTED ANSWER

      Re: Get Time out error EGL2153E when running EGL/Java on WebSphere on zOS

      ‏2012-12-06T18:49:21Z  in response to Apcheung
      Andy,

      I did followup with one of the developers. As I suspected, EGL does not use the setMaxInactiveInterval method... and there are no settings for the UI Gateway Service that would cause it to be used. You cannot modify this service to invoke it either.

      Basically, if you're debugging a web transaction (what uses the UI Gateway), there's a hard-coded timeout of 30 minutes.

      But for runtime, the EGL2153E only happens when the session times out or is invalidated. Those things aren't caused by the EGL code, but from external to us (i.e. the Application server or the web server).

      I think you need to double check that the settings are really being set, being used, and are the ones that needs to be changed.
      • Apcheung
        Apcheung
        7 Posts
        ACCEPTED ANSWER

        Re: Get Time out error EGL2153E when running EGL/Java on WebSphere on zOS

        ‏2012-12-06T19:48:40Z  in response to markevans
        Mark,

        I will double check my other setting on WAS and deployment descriptor.

        Thanks for the info.
        Andy.