IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 2 replies
  • Latest Post - ‏2012-12-03T23:37:43Z by IanDallas
IanDallas
IanDallas
4 Posts

Pinned topic ConfigureListener

‏2012-12-03T15:35:55Z |
Am getting this exception after I manually installed the DSUI on MDM v10.1 on my PC RSA environment. This happens when WAS 8 starts up:

03/12/12 15:31:34:178 GMT 00000014 webapp E com.ibm.ws.webcontainer.webapp.WebApp logError SRVE0293E: Servlet Error-Failed to load listener: com.sun.faces.config.ConfigureListener: java.lang.ClassNotFoundException: class java.lang.ClassNotFoundException: com.sun.faces.config.ConfigureListener
at java.beans.Beans.instantiate(Beans.java:190)
at java.beans.Beans.instantiate(Beans.java:75)
at com.ibm.ws.webcontainer.webapp.WebApp.loadListener(WebApp.java:1608)
at com.ibm.ws.webcontainer.webapp.WebAppImpl.loadListener(WebAppImpl.java:1163)
at com.ibm.ws.webcontainer.webapp.WebApp.loadLifecycleListeners(WebApp.java:1518)
at com.ibm.ws.webcontainer.webapp.WebAppImpl.initialize(WebAppImpl.java:408)
at com.ibm.ws.webcontainer.webapp.WebGroupImpl.addWebApplication(WebGroupImpl.java:88)
at com.ibm.ws.webcontainer.VirtualHostImpl.addWebApplication(VirtualHostImpl.java:169)
at com.ibm.ws.webcontainer.WSWebContainer.addWebApp(WSWebContainer.java:748)
at com.ibm.ws.webcontainer.WSWebContainer.addWebApplication(WSWebContainer.java:633)
at com.ibm.ws.webcontainer.component.WebContainerImpl.install(WebContainerImpl.java:422)
at com.ibm.ws.webcontainer.component.WebContainerImpl.start(WebContainerImpl.java:714)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1138)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1369)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:638)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:967)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:744)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2131)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:445)
at com.ibm.ws.runtime.component.CompositionUnitImpl.start(CompositionUnitImpl.java:123)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:388)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.access$500(CompositionUnitMgrImpl.java:116)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl$CUInitializer.run(CompositionUnitMgrImpl.java:994)
at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:349)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1650)

Any ideas?

This is the error I get when I try and run the DSUI:

03/12/12 15:38:14:491 GMT 00000067 webapp E com.ibm.ws.webcontainer.webapp.WebApp logServletError SRVE0293E: Servlet Error-[/timeout.jsp]: java.lang.RuntimeException: FacesContext not found
at javax.faces.webapp.UIComponentClassicTagBase.getFacesContext(UIComponentClassicTagBase.java:324)
at javax.faces.webapp.UIComponentClassicTagBase.setJspId(UIComponentClassicTagBase.java:226)
at com.ibm._jsp._timeout._jspService(_timeout.java:122)
at com.ibm.ws.jsp.runtime.HttpJspBase.service(HttpJspBase.java:99)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1147)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:722)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:449)
at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.handleRequest(ServletWrapperImpl.java:178)

Looks like a configuration issue... is probably handled by the MDM Installer, but obviously cant use that with PC/RSA etc
Updated on 2012-12-03T23:37:43Z at 2012-12-03T23:37:43Z by IanDallas
  • David_Radley
    David_Radley
    8 Posts

    Re: ConfigureListener

    ‏2012-12-03T17:47:10Z  
    Hi Ian,
    It looks like the JSF dependancy that the DS UI needs is not there in the WebSphere 8 runtime you are using. I wonder if this is caused by WebSphere 8 going up to JSF 2. I would suggest raising a PMR to get this investigated further, all the best, David.
  • IanDallas
    IanDallas
    4 Posts

    Re: ConfigureListener

    ‏2012-12-03T23:37:43Z  
    Hi Ian,
    It looks like the JSF dependancy that the DS UI needs is not there in the WebSphere 8 runtime you are using. I wonder if this is caused by WebSphere 8 going up to JSF 2. I would suggest raising a PMR to get this investigated further, all the best, David.
    From Tony Garrard:

    Looks like you haven't configured your jsf provider

    http://pic.dhe.ibm.com/infocenter/mdm/v10r1/index.jsp?topic=%2Fcom.ibm.mdmhs.dtshp.devgd.doc%2Fc_SettinguptheDSworkspace.html
    =========================

    Thanks that worked :-)

    Note: I had to delete the wstemp and temp folder in my WAS Profile folder - caching issue, then it worked perfectly.