• 2 replies
  • Latest Post - ‏2012-12-04T03:44:34Z by george.baker
344 Posts

Pinned topic RCP displaying global variables

‏2012-11-29T01:12:31Z |
I'm trying to place the contents of an indexed global variable on a RCP transformation. It works, but all the embedd blanks are reduced to a single blank. This happens in a Web transformation because the browser strips repetitive blanks. I was able to solve that issue by using <prev> "global variable data" </prev>.

How do I accomplish the same thing with a Rich Client?
Updated on 2012-12-04T03:44:34Z at 2012-12-04T03:44:34Z by george.baker
  • tmparker
    534 Posts

    Re: RCP displaying global variables

    Hi George,

    I'm not sure exactly how you are reproducing this so I am not sure what you are seeing. I tried inserting a GV into the RCP page and it shows fine. How are you determining if there are spaces there or not? The GV gets inserted as a label, I believe, so you can't see spaces around it. However, the label widget does have trim spaces turned on by default so maybe that is what you are having a problem with. Let me know if you are doing something different.

  • george.baker
    344 Posts

    Re: RCP displaying global variables

    I'm using v8.5. I do a HATS --> global varaible from the palette and drop the GV on the composite. The GV is an indexed GV. I specify the seperator as /n. Each entry represents a row in a table extracted from the screen. When I run the application all the data is there but it is not aligned as a table should. I thought the default font, Segoe UI, was a monospaced font, but went and changed the font from Segoe UI,9 to Courier New,9 and it aligned properly. I specified when creating the project to use monospaced fonts.

    There was no trim spaces in the global varaible properties.

    I don't understand why this works.