Topic
5 replies Latest Post - ‏2012-11-30T20:14:27Z by SystemAdmin
SystemAdmin
SystemAdmin
5507 Posts
ACCEPTED ANSWER

Pinned topic Resource Monitoring Issue

‏2012-11-28T18:49:01Z |
I am trying to set up resource monitoring on RPT 8.2.0.4 using rstatd, and I'm running into some trouble. I seem to be able to configure the resource monitor (as in, it seems to be able to find the rstatd server at configure time), but I'm not getting the results I've request at run time. Nothing appears under the RSTATD folder as expected.

I was wondering if you had any ideas on how I could fix this, or just what might be wrong?

If there is any other information I can provide, just let me know
Updated on 2012-11-30T20:14:27Z at 2012-11-30T20:14:27Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    5507 Posts
    ACCEPTED ANSWER

    Re: Resource Monitoring Issue

    ‏2012-11-28T18:49:30Z  in response to SystemAdmin
    Here is the current configuration:
    • petersda
      petersda
      346 Posts
      ACCEPTED ANSWER

      Re: Resource Monitoring Issue

      ‏2012-11-28T19:40:21Z  in response to SystemAdmin
      RPT 8.2.0.4 is really old. There have been several defect fixes made in this area since then. Trying rstatd in 8.3 seemed to work okay.

      What unix operating system are you using?
      • SystemAdmin
        SystemAdmin
        5507 Posts
        ACCEPTED ANSWER

        Re: Resource Monitoring Issue

        ‏2012-11-30T14:33:32Z  in response to petersda
        I have upgraded to RPT v8.3 and I am stil experiencing the same issue. The machine I am trying to monitor is SLES 11.2.

        I should also mention that I had to download and build RSTATD because the os did not come with it. It is possible there is a problem with RSTATD. Does anyone know how I can verify if rstatd is working?
        • SystemAdmin
          SystemAdmin
          5507 Posts
          ACCEPTED ANSWER

          Re: Resource Monitoring Issue

          ‏2012-11-30T15:06:25Z  in response to SystemAdmin
          When running "rup localhost" on the machine running rstatd, I get this back:
          rup: RPC; Success

          and nothing else...
          • SystemAdmin
            SystemAdmin
            5507 Posts
            ACCEPTED ANSWER

            Re: Resource Monitoring Issue

            ‏2012-11-30T20:14:27Z  in response to SystemAdmin
            As it turns out, rstatd v4.0.1-4 does not work with 3.x Linux kernels. See site for details: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=654276

            I installed the fixpack v4.0.1-7 from here: http://packages.debian.org/wheezy/rstatd

            Now resource monitoring seems to almost be working. RPT is reporting CPU usage statistics. The only issue is that the graph ends up as a vertical line. There must be something wrong with the timestamp or something in that data returned by rstatd.

            I will continue to investigate, but if anyone has any ideas on what might be wrong and/or how to fix it, please let me know.