Topic
  • 3 replies
  • Latest Post - ‏2012-11-29T11:51:46Z by jacquesrage
jacquesrage
jacquesrage
11 Posts

Pinned topic connectivity for sql adapter on worklight server

‏2012-11-28T15:27:03Z |
hi,
how to declare an sql connection for my adapter deployed on the worklight server.
does the dataSourceDefinition declare in the xml adapter still used or do i need to configure a
datasource in the web.xml of tomcat ?
thanks
  • AntonAleksandrov
    AntonAleksandrov
    2 Posts

    Re: connectivity for sql adapter on worklight server

    ‏2012-11-29T09:13:05Z  
    Hello,

    You can see tutorial on setting up SQL adapter here - http://public.dhe.ibm.com/ibmdl/export/pub/software/mobile-solutions/worklight/docs/Module_05_1_-_Creating_SQL_Adapters.pdf

    Also, a sample SQL adapter is available here - http://public.dhe.ibm.com/ibmdl/export/pub/software/mobile-solutions/worklight/docs/module_05_1_SQL_Adapter.zip
  • jacquesrage
    jacquesrage
    11 Posts

    Re: connectivity for sql adapter on worklight server

    ‏2012-11-29T11:18:21Z  
    Hello,

    You can see tutorial on setting up SQL adapter here - http://public.dhe.ibm.com/ibmdl/export/pub/software/mobile-solutions/worklight/docs/Module_05_1_-_Creating_SQL_Adapters.pdf

    Also, a sample SQL adapter is available here - http://public.dhe.ibm.com/ibmdl/export/pub/software/mobile-solutions/worklight/docs/module_05_1_SQL_Adapter.zip
    hi, yes this step is working well in a developpement environnement. when i deploy the wlapp and adapter in the server
    the adapter can't connect to my jdbc source specified in the xml file of the adapter.
    thanks
  • jacquesrage
    jacquesrage
    11 Posts

    Re: connectivity for sql adapter on worklight server

    ‏2012-11-29T11:51:46Z  
    hi, yes this step is working well in a developpement environnement. when i deploy the wlapp and adapter in the server
    the adapter can't connect to my jdbc source specified in the xml file of the adapter.
    thanks
    ok my context was incorrect. this thread help me to correct it and now the connection to my sql source is fine.
    https://www.ibm.com/developerworks/forums/thread.jspa?messageID=14884241