Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
5 replies Latest Post - ‏2012-12-10T14:29:32Z by SystemAdmin
SystemAdmin
SystemAdmin
5507 Posts
ACCEPTED ANSWER

Pinned topic Test run stopped due to agent driver has reported it not recieving msgs

‏2012-11-28T12:36:23Z |
Hi

In in load test, RPT suddenly showed up this error and The test got stopped. Also the application was performing poorly at that time, but RPT test was not supposed to stop. Please can you help on why this issue happened.

Error message
"Test Run stopped due to error
Driver (on Agent) has reported that it is no longer receiving messages from the workbench. The previous message recieved from this driver, 69779 milliseconds.
"
Thanks
Shambu
Updated on 2012-12-10T14:29:32Z at 2012-12-10T14:29:32Z by SystemAdmin
  • RobertoFdez
    RobertoFdez
    50 Posts
    ACCEPTED ANSWER

    Re: Test run stopped due to agent driver has reported it not recieving msgs

    ‏2012-11-29T08:31:57Z  in response to SystemAdmin
    Check the CPU Usage of the agent. Maybe is at 100% and it is unable to send any message to your RPT.
    • SystemAdmin
      SystemAdmin
      5507 Posts
      ACCEPTED ANSWER

      Re: Test run stopped due to agent driver has reported it not recieving msgs

      ‏2012-11-29T14:58:09Z  in response to RobertoFdez
      Thanks for the reply.

      I did check the CPU utilization of the agent servers. They were hardly doing anything near 10-15 %

      Shambu
      • SystemAdmin
        SystemAdmin
        5507 Posts
        ACCEPTED ANSWER

        Re: Test run stopped due to agent driver has reported it not recieving msgs

        ‏2012-11-30T05:38:06Z  in response to SystemAdmin
        I was facing the same issue while working on RPT 8.3 versions using Windows 7 and IE 9. In my case, i was not getting errors anywhere, CPU utilization was fine..to my surpise, the issue was withe Power options under Control panel.

        The power shut down for display and hard disk was set to 20 minutes. So, my test was working fine and after 20-30 minutes, the test stops stating the same error. Please check Power options under Control Panel and change them to 'Never' category. The tests should be running fine if all other things are working correctly. Please try.
  • SystemAdmin
    SystemAdmin
    5507 Posts
    ACCEPTED ANSWER

    Re: Test run stopped due to agent driver has reported it not recieving msgs

    ‏2012-12-04T17:16:22Z  in response to SystemAdmin
    I've been having this same problem with RPT v8.3. I tried changing my statistics interval from 10 seconds to 30 seconds, and that seemed to solve it for me. Maybe try that.
    • SystemAdmin
      SystemAdmin
      5507 Posts
      ACCEPTED ANSWER

      Re: Test run stopped due to agent driver has reported it not recieving msgs

      ‏2012-12-10T14:29:32Z  in response to SystemAdmin
      Thanks all for your response. I added following arguments to Agent in workbench. This seems to have resolved as we did not have the issue with RPT not collecting statistics. To be more safe, I will increase the statistics collection interval to 30 seconds as suggested here.