Topic
  • 13 replies
  • Latest Post - ‏2013-08-29T20:20:08Z by Khilnani
SystemAdmin
SystemAdmin
445 Posts

Pinned topic IBM Content Navigator sample plugin jar file was not found

‏2012-11-28T08:03:32Z |
I am working on an IBM Content Navigator Plugin. I want to add a new plugin to IBM Content Navigator. I have the jar file of the plugin uploaded to a WebSphere server, and I can reach that jar file by using the browser,however I get an error when I do the same using the IBM Content Navigator Plugin screen. I am unable to load the plugin jar file to IBM Content Navigator. I have tried both URL Path and File Path; I keep getting this error: "The plug-in JAR file was not found at the specified URL. Ensure that the JAR file is on the web application server and that the URL and file name are correct."
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-11-28T09:04:10Z  
    Have a look inside the WebSphere's appserver logs to find the full stacktrace. Are you using the provided sample plugin or is it a plugin you wrote? One other common error that might have occurred but is not highlighted well from the error message is the missing "Plugin-Class" reference in the plugin's jar manifest. Do you have that specified in your plugin jar?
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-11-28T09:45:34Z  
    Have a look inside the WebSphere's appserver logs to find the full stacktrace. Are you using the provided sample plugin or is it a plugin you wrote? One other common error that might have occurred but is not highlighted well from the error message is the missing "Plugin-Class" reference in the plugin's jar manifest. Do you have that specified in your plugin jar?
    I am using the plugin named "CloseAccountPlugin" from the Redbook "Customizing and Extending IBM Content Navigator". I get this message in the WebSphere's appserver log:
    com.ibm.ecm.util.PluginUtil.loadPlugins() Exception loading plug-in E:\IBM\ECMClient\plugins\CloseAccountPlugin.jar
    java.lang.ClassNotFoundException: com.ibm.ecm.extension.CloseAccountPlugin

    and my MANIFEST.MF file is like this:
    Manifest-Version: 1.0
    Ant-Version: Apache Ant 1.7.0
    Created-By: 2.4 (IBM Corporation)
    Plugin-Class: com.ibm.ecm.extension.CloseAccountPlugin
    Name: build
    Built-By: ayilmaz
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-11-28T11:46:03Z  
    I am using the plugin named "CloseAccountPlugin" from the Redbook "Customizing and Extending IBM Content Navigator". I get this message in the WebSphere's appserver log:
    com.ibm.ecm.util.PluginUtil.loadPlugins() Exception loading plug-in E:\IBM\ECMClient\plugins\CloseAccountPlugin.jar
    java.lang.ClassNotFoundException: com.ibm.ecm.extension.CloseAccountPlugin

    and my MANIFEST.MF file is like this:
    Manifest-Version: 1.0
    Ant-Version: Apache Ant 1.7.0
    Created-By: 2.4 (IBM Corporation)
    Plugin-Class: com.ibm.ecm.extension.CloseAccountPlugin
    Name: build
    Built-By: ayilmaz
    I found where the problem was; the Plugin-Class in the MANIFEST.MF file must be
    com.ibm.ecm.extension.CloseAccountPlugin.CloseAccountPlugin,
    I added the plugin to the menu, but now I get another error from IBM Content Navigator which says there is a problem with JavaScript files.
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-01T17:51:40Z  
    I found where the problem was; the Plugin-Class in the MANIFEST.MF file must be
    com.ibm.ecm.extension.CloseAccountPlugin.CloseAccountPlugin,
    I added the plugin to the menu, but now I get another error from IBM Content Navigator which says there is a problem with JavaScript files.
    You will need to get firebug for firefox or use Chrome's native developer console to look at the javascript error in the browser. It will be part of the Javascript logging done by ICN so do a search for CIWEB ERROR
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-03T15:07:54Z  
    You will need to get firebug for firefox or use Chrome's native developer console to look at the javascript error in the browser. It will be part of the Javascript logging done by ICN so do a search for CIWEB ERROR
    I had created a new Dynamic Web Project for the CloseAccountPlugin example to be able to create an EAR File, when I deployed it I got an error message about the JavaScript files.
    Before that, I had created a normal Java project for the same example and I had the jar file of this project, so I used this jar file with the IBM Content Navigator.
    I followed all the steps defined in the book "Customizing and Extending IBM Content Navigator", Chapter 6, I compiled the project (which has 11 files) created the jar file and deployed it to the ICN.
    I did all the steps defined in "6.4 Deploying and configuring the plug-in", the problem is, I don't get any errors and nothing happens, no dialog-box is displayed and nothing new appears in the menu.
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-06T14:06:06Z  
    I had created a new Dynamic Web Project for the CloseAccountPlugin example to be able to create an EAR File, when I deployed it I got an error message about the JavaScript files.
    Before that, I had created a normal Java project for the same example and I had the jar file of this project, so I used this jar file with the IBM Content Navigator.
    I followed all the steps defined in the book "Customizing and Extending IBM Content Navigator", Chapter 6, I compiled the project (which has 11 files) created the jar file and deployed it to the ICN.
    I did all the steps defined in "6.4 Deploying and configuring the plug-in", the problem is, I don't get any errors and nothing happens, no dialog-box is displayed and nothing new appears in the menu.
    There is a progress with the project.
    The name of the default desktop we use is BBS.
    When we connect to the ICN through "IP:9080/navigator" the CloseAccountAction button does not appear in the toolbar, but when we connect through "IP:9080/navigator/?desktop=BBS" the CloseAccountAction button appears in the toolbar, what can be the cause? Both adresses point to the same desktop.
    And another thing; when we select a file that enables the CloseAccountAction button and click on the button we get a "CIWEB2002 A connection to web_client_URL cannot be established" error.
    What can be the cause? Thanks.
  • damorris
    damorris
    825 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-06T14:16:21Z  
    There is a progress with the project.
    The name of the default desktop we use is BBS.
    When we connect to the ICN through "IP:9080/navigator" the CloseAccountAction button does not appear in the toolbar, but when we connect through "IP:9080/navigator/?desktop=BBS" the CloseAccountAction button appears in the toolbar, what can be the cause? Both adresses point to the same desktop.
    And another thing; when we select a file that enables the CloseAccountAction button and click on the button we get a "CIWEB2002 A connection to web_client_URL cannot be established" error.
    What can be the cause? Thanks.
    The first issue is due to a bug in ICN 2.0.0 that didn't apply the desktop settings correctly to the default desktop. I thought this was fixed in Fixpack 1 - have you installed that? If not, we have a new release coming out soon that certainly addresses this issue.

    For the second one, that's something you'd have to debug in your plugin. I would use Firefox and install Firebug and then look at the Net tabs and the console to see if you are getting a JS error. You can also check the server logs to see if an exception was thrown on the server side.
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-06T14:56:38Z  
    • damorris
    • ‏2012-12-06T14:16:21Z
    The first issue is due to a bug in ICN 2.0.0 that didn't apply the desktop settings correctly to the default desktop. I thought this was fixed in Fixpack 1 - have you installed that? If not, we have a new release coming out soon that certainly addresses this issue.

    For the second one, that's something you'd have to debug in your plugin. I would use Firefox and install Firebug and then look at the Net tabs and the console to see if you are getting a JS error. You can also check the server logs to see if an exception was thrown on the server side.
    I had checked firebug and the logs, found no js errors and the logs didn't help much.
    The first issue in my previous post is not included in Fixpack 1 which we have already installed. When will the new release be available? Thanks.
  • damorris
    damorris
    825 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-06T14:59:07Z  
    I had checked firebug and the logs, found no js errors and the logs didn't help much.
    The first issue in my previous post is not included in Fixpack 1 which we have already installed. When will the new release be available? Thanks.
    I can't give an exact date but before year's end.
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-06T17:59:31Z  
    I had checked firebug and the logs, found no js errors and the logs didn't help much.
    The first issue in my previous post is not included in Fixpack 1 which we have already installed. When will the new release be available? Thanks.
    Hmm that's odd. The first scenario you described should have been fixed in fixpack1. Can you make sure fixpack1 was applied appropriately? Can you view the About Screen and list out the build version and number? I am just curious. Thanks.
  • SystemAdmin
    SystemAdmin
    445 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2012-12-07T13:47:00Z  
    Hmm that's odd. The first scenario you described should have been fixed in fixpack1. Can you make sure fixpack1 was applied appropriately? Can you view the About Screen and list out the build version and number? I am just curious. Thanks.
    You were right, after loading Fixpack 1 the first scenario was solved, the CloseAccountAction button appears in the toolbar, but we are still stuck to the CIWEB2002 error.
  • konapalligopi
    konapalligopi
    62 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2013-05-08T01:59:54Z  
    You were right, after loading Fixpack 1 the first scenario was solved, the CloseAccountAction button appears in the toolbar, but we are still stuck to the CIWEB2002 error.

    Team,

    Facing the same problem. I am getting the Action button in the toolbar but  when i am performing that action it is throwing alert with CIWEB2002 error. Can somebody help us to track this issue. I am getting an Error in the Systemout log as below.

    CIWEB Error: [p8admin @ 172.20.10.5] com.ibm.ecm.struts.actions.PluginAction.isSecureService() Invalid plugin id: CloseAccountPlugin.  This is likely a logic error in the plugin itself.
    CIWEB Error: [p8admin @ 172.20.10.5] com.ibm.ecm.struts.actions.PluginAction.isSecureService() Invalid plugin id: CloseAccountPlugin.  This is likely a logic error in the plugin itself.

    Please let me know if any more details required.

  • Khilnani
    Khilnani
    6 Posts

    Re: IBM Content Navigator sample plugin jar file was not found

    ‏2013-08-29T20:20:08Z  

    Team,

    Facing the same problem. I am getting the Action button in the toolbar but  when i am performing that action it is throwing alert with CIWEB2002 error. Can somebody help us to track this issue. I am getting an Error in the Systemout log as below.

    CIWEB Error: [p8admin @ 172.20.10.5] com.ibm.ecm.struts.actions.PluginAction.isSecureService() Invalid plugin id: CloseAccountPlugin.  This is likely a logic error in the plugin itself.
    CIWEB Error: [p8admin @ 172.20.10.5] com.ibm.ecm.struts.actions.PluginAction.isSecureService() Invalid plugin id: CloseAccountPlugin.  This is likely a logic error in the plugin itself.

    Please let me know if any more details required.

    Hi,

    I am getting the same error.

    CIWEB Error: [fnadmin @ 9.74.130.74] com.ibm.ecm.struts.actions.PluginAction.isSecureService() Invalid plugin id: CloseAccountPlugin.  This is likely a logic error in the plugin itself.

    Any resolution?

    Also, how to enable the debugging for this? I enabled the logging class in ICN settings but no luck.

    Thanks.