Topic
  • 3 replies
  • Latest Post - ‏2012-12-31T13:03:15Z by SystemAdmin
SystemAdmin
SystemAdmin
340 Posts

Pinned topic Error in verifying the agent id

‏2012-11-21T05:43:33Z |
Hello,
In agent error.log and trace.log I see this error.
"-999-Error in verifying the agent id"
Updated on 2012-12-31T13:03:15Z at 2012-12-31T13:03:15Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: Error in verifying the agent id

    ‏2012-11-22T19:44:24Z  
    Hello Srinivas,

    At the first glance it looks like rare abnormal situation that should be opened as PMR, however let me understand the issue better. Could you please answer to the following questions:

    1. What is the scenario you performed?
    • you installed new agent (if yes, what command did you issue? how does it look like the response file if you used it?)
    • you upgrade an agent (if yes from which version to which version?)
    • agents was working fine and such error suddenly appeared (if yes, what have been done recently in your environment and what actions were performed on the ILMT server?)

    2. What is the version of the agent you use?

    3. What is your OS (platform, version, subversion)?

    4. Are you able to run
    tlmagent -p
    on the agent? (if not, what message appears on the console and in the logs?)

    Regards,
    Michał Klak
    ILMT Central Team


    The postings on this site are my own and do not necessarily represent IBM's positions, strategies or opinions.
    Please contact product support if you need IBM's official advice.

    If you want to extend your knowledge of ILMT, you may check this site:
    https://www.ibm.com/developerworks/mydeveloperworks/wikis/home/wiki/IBM+License+Metric+Tool
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: Error in verifying the agent id

    ‏2012-12-28T10:11:08Z  
    Hello Srinivas,

    At the first glance it looks like rare abnormal situation that should be opened as PMR, however let me understand the issue better. Could you please answer to the following questions:

    1. What is the scenario you performed?
    • you installed new agent (if yes, what command did you issue? how does it look like the response file if you used it?)
    • you upgrade an agent (if yes from which version to which version?)
    • agents was working fine and such error suddenly appeared (if yes, what have been done recently in your environment and what actions were performed on the ILMT server?)

    2. What is the version of the agent you use?

    3. What is your OS (platform, version, subversion)?

    4. Are you able to run
    tlmagent -p
    on the agent? (if not, what message appears on the console and in the logs?)

    Regards,
    Michał Klak
    ILMT Central Team


    The postings on this site are my own and do not necessarily represent IBM's positions, strategies or opinions.
    Please contact product support if you need IBM's official advice.

    If you want to extend your knowledge of ILMT, you may check this site:
    https://www.ibm.com/developerworks/mydeveloperworks/wikis/home/wiki/IBM+License+Metric+Tool
    Hi Michael,

    Please find my answers for your questions

    1. What is the scenario you performed?
    • agents was working fine and such error suddenly appeared and agents started missing hardware scans. Nothing predominant changes were done for agent side, but on server side new catalog version was uploaded (September catalog) and also PVU table was updated.

    2. What is the version of the agent you use?
    --7.2.2.1 agent version

    3. What is your OS (platform, version, subversion)?
    • Most of the issue are in windows 2008 server

    4. Are you able to run
    tlmagent -p
    on the agent?
    • Yes I am able to run the command successfully.

    Thanks,
    Srinivas
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: Error in verifying the agent id

    ‏2012-12-31T13:03:15Z  
    Hi Michael,

    Please find my answers for your questions

    1. What is the scenario you performed?
    • agents was working fine and such error suddenly appeared and agents started missing hardware scans. Nothing predominant changes were done for agent side, but on server side new catalog version was uploaded (September catalog) and also PVU table was updated.

    2. What is the version of the agent you use?
    --7.2.2.1 agent version

    3. What is your OS (platform, version, subversion)?
    • Most of the issue are in windows 2008 server

    4. Are you able to run
    tlmagent -p
    on the agent?
    • Yes I am able to run the command successfully.

    Thanks,
    Srinivas
    Hello Srinivas,

    Please import the newest version of Software Catalog and follow the instruction from this post:
    General Procedure

    What I'm especially interested is the information if
    
    tlmagent -hw
    
    command will work or not.

    Regards,
    Michał Klak
    ILMT Central Team


    The postings on this site are my own and do not necessarily represent IBM's positions, strategies or opinions.
    Please contact product support if you need IBM's official advice.

    If you want to extend your knowledge of ILMT, you may check this site:
    https://www.ibm.com/developerworks/mydeveloperworks/wikis/home/wiki/IBM+License+Metric+Tool