Topic
5 replies Latest Post - ‏2013-01-18T17:51:30Z by ArpitKumarGarg
SystemAdmin
SystemAdmin
1192 Posts
ACCEPTED ANSWER

Pinned topic Issue in ">" Symbol

‏2012-11-20T13:23:45Z |
Hi ,

In Mainframe they are designed such a way like if we enter ">"(greater than) symbol in the First position then they are done the delete operation (delete the record)

In IBM HATS Tool , if we enter the ">" symbol in first position it's not recognizing , in that same position it's recognizance other symbols and characters , even if we give the ">" symbol in second position it's recognizing the new values

NOTE : This is happens in only our project , if we create the new HATS project it's working fine.Is there any settings available

Can you please provide the suggestions

Thanks
Siva S
Updated on 2013-01-18T17:51:30Z at 2013-01-18T17:51:30Z by ArpitKumarGarg
  • SanthiRamala
    SanthiRamala
    34 Posts
    ACCEPTED ANSWER

    Re: Issue in ">" Symbol

    ‏2012-11-20T14:32:09Z  in response to SystemAdmin
    Hi Siva,

    Create another simple HATS project and try to compare your project HATS default files with this new project files.
    See if you can find any thing interesting with respect to the issue.
    Bets Regards
    Santhi
    • SystemAdmin
      SystemAdmin
      1192 Posts
      ACCEPTED ANSWER

      Re: Issue in ">" Symbol

      ‏2013-01-05T01:36:12Z  in response to SanthiRamala
      Hi Siva, Could you advise how this issue was resolved? I'm having the same issue now. Pls advise ASAP.
      • vbhatia
        vbhatia
        1 Post
        ACCEPTED ANSWER

        Re: Issue in ">" Symbol

        ‏2013-01-06T14:41:45Z  in response to SystemAdmin
        Anji,

        If you create a new project does the greater-than symbol work? Could be some setting which is different?

        • Vineet
  • SystemAdmin
    SystemAdmin
    1192 Posts
    ACCEPTED ANSWER

    Re: Issue in ">" Symbol

    ‏2013-01-17T19:58:55Z  in response to SystemAdmin
    This is happening because ">" symbol is recognized as 'light Pen field' in the HATS(It is a setting checked when the project is created).
    I'm able to pass the ">" sign to PMS by making the "Light Pen Mode" to False. This is a project level setting.
    • ArpitKumarGarg
      ArpitKumarGarg
      2 Posts
      ACCEPTED ANSWER

      Re: Issue in ">" Symbol

      ‏2013-01-18T17:51:30Z  in response to SystemAdmin
      Hi
      > symbol does not recognize as a light pen field.Concept of rendering of light pen field in HATS is as below:

      The light pen (selection) component is responsible for recognizing a light pen (also known as selector pen) selection field on 3270 host screens.
      In HATS,light pen support is enabled by selecting the Add light pen rendering support check box during the initial creation of a 3270 or 3270E project.

      A recognized light pen selection field can be rendered by the Check box widget.

      If the designator character (the first character of the field) is a question mark (?), the rendered check box is not selected.
      If the designator character is a greater-than sign (>), the rendered check box is selected.

      Because > sign is designator character for Light pen field in HATS, that's why it does not pass to the Host.

      But if you want light pen field behave as a normal field in HATS, then you have to disable the " Add light pen rendering suppport" checkbox.
      Then, you can pass '>' symbol to the host screen.