Topic
6 replies Latest Post - ‏2012-11-30T15:33:13Z by SystemAdmin
SystemAdmin
SystemAdmin
2327 Posts
ACCEPTED ANSWER

Pinned topic Blank screen in Windows Phone emulator

‏2012-11-20T07:15:38Z |
I am trying to move with existing demo project from android and ios to windows phone. After I got blank (white) screen in WP emulator I fell back from 5.0.3 to 5.0.2 with some example code without success. Finally I stuck on empty project w/o any dependent JS library that has only changed colors (to make sure it is not white). Results is correct on other platforms, on WP browser it is still fine, but WP emulator from Visual Studio does not show content (only colored background) - see attached screenshot.

Windows Phone emulator works fine, I can click through it, even though it complains on startup about missing hardware acceleration. Visual studio console log does not show problems. I have no idea what is wrong. BTW, any hints how to debug webapp from within emulator (weinre equivalent)?

Operation System: Windows 7 x64 on VMware Workstation 7.0.1
Eclipse: JEE 3.7.2
Worklight plug-in: 5.0.2 (consumer edition)
Environment details: WindowsPhone (Visual Studio 2010 Express) Windows CE 7.0 and 7.1

regards,
andy
  • SystemAdmin
    SystemAdmin
    2327 Posts
    ACCEPTED ANSWER

    Re: Blank screen in Windows Phone emulator

    ‏2012-11-20T16:50:02Z  in response to SystemAdmin
    Wait for 5.0.5 release
    • Paramasivan.G
      Paramasivan.G
      33 Posts
      ACCEPTED ANSWER

      Re: Blank screen in Windows Phone emulator

      ‏2012-11-21T04:01:55Z  in response to SystemAdmin
      Hi Jerry,
      When can we expect for the Release of 5.0.5 approx???
      Thanks

      Paramasivan G
  • IdanAdar
    IdanAdar
    741 Posts
    ACCEPTED ANSWER

    Re: Blank screen in Windows Phone emulator

    ‏2012-11-25T06:08:44Z  in response to SystemAdmin
    IBM Worklight v5.0.5 has already been announced. It will be released in the coming weeks.
    That said, Windows Phone is already supported, and working. There is no need to wait for 5.0.5...

    Can you attach your example project?

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
    • SystemAdmin
      SystemAdmin
      2327 Posts
      ACCEPTED ANSWER

      Re: Blank screen in Windows Phone emulator

      ‏2012-11-23T14:25:29Z  in response to IdanAdar
      Idan,
      find project export attached. As I said it is nearly empty app template:
      a) I created 5.0.2 project with hybrid app
      b) I modified html file disabling connecting to WL server (body onload with WL.client.init() param)
      c) Copied app name label to make sure it fills in screen (in case of layout problems in WinPhone emulator)
      d) Changed css file adding foreground and background colors.
      e) Created windows phone environment to open in in visual studio
      This is it.

      I am not sure the root cause of the problem as I am working within vmware. I do not want to mess up with my host environment (also Win7 x64) as well as my goal is to prepare to work on MacBoook where vmware is the only way to have visual studio for WinPhone up and running.

      regards,
      -andy.

      Attachments

  • IdanAdar
    IdanAdar
    741 Posts
    ACCEPTED ANSWER

    Re: Blank screen in Windows Phone emulator

    ‏2012-11-25T06:15:21Z  in response to SystemAdmin
    Hello,

    I have taken your project and for me it works.
    Please see attached screen shot.

    From past experience with Windows Phone development, when you get a warning about graphics card, the emulator really won't work well.
    It could very well be that the machine running the VM does not have a good enough graphics card required by Microsfot for when using the Windws Phone emulator...

    My suggestion would be to try on a Windows machine to verify this is indeed the issue.

    Idan Adar
    QA Engineer
    IBM Worklight Mobile Platform
    • SystemAdmin
      SystemAdmin
      2327 Posts
      ACCEPTED ANSWER

      Re: Blank screen in Windows Phone emulator

      ‏2012-11-30T15:33:13Z  in response to IdanAdar
      Idan,
      on host machine it works indeed.

      Thank you for your patience, I did not want to generate additional load for support team and I should've tried it on my own. My excuse is I was trying not to mess up my host environment as MS products deeply integrate with OS...

      I did more research and it looks that there is no way to have WP7 emulator in virtualized environment: emulator requirements states it needs WDDM 1.1 and DDI 10 drivers level as a minimum, while even most recent vmware (workstation 9.0.1, player 5.0.1) still has graphic drivers on WDDM 1.0 and DDI 9Ex level. I could not find any successful story with any virtual machine. Of course that does not preclude from using real windows phone in virtual environment which is proven practice but not my case as I am more about testing/presenting different platforms on one system.
      regards,
      -andy.