Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
6 replies Latest Post - ‏2012-12-10T09:45:51Z by SystemAdmin
frenchbrian
frenchbrian
16 Posts
ACCEPTED ANSWER

Pinned topic Receiving 500com.google.gwt.user.client.rpc.StatusCodeException: error

‏2012-11-19T17:40:15Z |
We upgraded to BPM 8.0.1 over the weekend. While some people are able to login to Process Designer successfully, others cannot. The Process Designer trys to authenticate with the server, and actually opens the Process Designer, but then gives this message:

500com.google.gwt.user.client.rpc.StatusCodeException: The call failed on the server; see server log for details

What is interesting is I can login from one laptop using my normal login. From a different laptop, I cannot login using the same credentials. We have about 10 people on the team, and all only two of us are able to login successfully.

We have all upgraded our Process Designers to 8.0.1. Info from the server log:

11/19/12 8:58:20:750 PST 000000b7 wle_security I CWLLG1088I: Initializing session is done for user bafrench
11/19/12 8:58:45:656 PST 000000b6 wle_security I CWLLG1088I: Initializing session is done for user bafrench
11/19/12 8:59:05:734 PST 00000067 webapp I com.ibm.ws.webcontainer.webapp.WebApp log SRVE0296E: http://IBM_BPM_Repository_vhost1206Node01_server1#repository.war[/ProcessCenter]http://Servlet.LOG:.Exception while dispatching incoming RPC call:.java.lang.SecurityException: Blocked request without GWT permutation header (XSRF attack?)
at com.google.gwt.user.server.rpc.RemoteServiceServlet.checkPermutationStrongName(RemoteServiceServlet.java:272)

Brian French | President | Salient Process LLC
Updated on 2012-12-10T09:45:51Z at 2012-12-10T09:45:51Z by SystemAdmin
  • kolban
    kolban
    3315 Posts
    ACCEPTED ANSWER

    Re: Receiving 500com.google.gwt.user.client.rpc.StatusCodeException: error

    ‏2012-11-19T17:48:28Z  in response to frenchbrian
    I bumped into this one myself this morning and I suspect the majority of us will hit it too. What I did to resolve the issue was to clear my browser cache/cookies and then try again. Immediately after doing that, it worked.

    What I suspect is happening is that in moving from 8.0.0 to 8.0.1 some "underlying" library change happened. The product leverages Google GWT user interface technology and I suspect a cache of previous code or cookies is being held by the browser. Once that cache is purged, all seems to work.

    My opinion is that it should have worked without having to clear the cache ... but this appears to be a workaround. Please let me know what you find and if it worked.

    Neil
    • frenchbrian
      frenchbrian
      16 Posts
      ACCEPTED ANSWER

      Re: Receiving 500com.google.gwt.user.client.rpc.StatusCodeException: error

      ‏2012-11-19T19:14:45Z  in response to kolban
      Thanks Neil! That seems to have potential, and is working for some of us but not all of us. We will continue trying...

      Brian French | President | Salient Process LLC
      • SystemAdmin
        SystemAdmin
        7615 Posts
        ACCEPTED ANSWER

        Re: Receiving 500com.google.gwt.user.client.rpc.StatusCodeException: error

        ‏2012-11-21T14:12:15Z  in response to frenchbrian
        Brian,
        Perhaps you have cleared the cache of the browser that is set as non-default one? PD uses the default browser in the system.

        --Sergei
      • SystemAdmin
        SystemAdmin
        7615 Posts
        ACCEPTED ANSWER

        Re: Receiving 500com.google.gwt.user.client.rpc.StatusCodeException: error

        ‏2012-11-21T15:44:32Z  in response to frenchbrian
        One more thing - the restart of the process center environment has helped one other person to resolve the issue...
        • frenchbrian
          frenchbrian
          16 Posts
          ACCEPTED ANSWER

          Re: Receiving 500com.google.gwt.user.client.rpc.StatusCodeException: error

          ‏2012-11-22T20:47:42Z  in response to SystemAdmin
          The issue is mostly resolved by having had people clear their browser cache. We have about ten people accessing the Process Center, and only two of them still have the issue. I will provide another update once everyone has been able to resolve the issue.

          Brian French | President | Salient Process LLC
  • SystemAdmin
    SystemAdmin
    7615 Posts
    ACCEPTED ANSWER

    Re: Receiving 500com.google.gwt.user.client.rpc.StatusCodeException: error

    ‏2012-12-10T09:45:51Z  in response to frenchbrian
    Clearing Internet Explorer cache and cookies helps. As I can see Eclipse uses some of IE libraries to present content.