Topic
  • 2 replies
  • Latest Post - ‏2012-11-20T16:04:04Z by jsuch
jsuch
jsuch
11 Posts

Pinned topic Portal Express 6.1 on Linux: Update from 6.1.0.4 to 6.1.0.6 failed.

‏2012-11-19T14:20:53Z |
Hello,

I tried to update PE to newest patch: 6.1.0.6 but after several minutes updatePortalWizard.sh
failed with strange message:
"Unable to locate /opt/IBM/WebSphere/PortalExpress/PortalServer/installer/wp.config/wps.properties ensure Portal has been installed properly."

Another strange thing, perhaphs related: UpdatePortalWizard.sh cannot detect valid PE install at startup & I must manually eneter path: /opt/IBM/WebSphere/PortalExpress/PortalServer/.

WAS, HTTP, plugins were previously updated.
DB2 was started but not updated.
Yes, I know that it should be done, but in the past I didn't have to care about DB2 fixpack level ...

I attached logs.

Please help or make any suggestions...

best regards
Janusz Such

Attachments

Updated on 2012-11-20T16:04:04Z at 2012-11-20T16:04:04Z by jsuch
  • httweed
    httweed
    510 Posts

    Re: Portal Express 6.1 on Linux: Update from 6.1.0.4 to 6.1.0.6 failed.

    ‏2012-11-19T14:31:10Z  
    Hi, this is a defect with the 6106 upgrade on Portal Express. I have attached a workaround to this post. Follow these instructions:

    1. Remove (do not rename) this file:

    /opt/IBM/WebSphere/PortalExpress/PortalServer/jcr/prereq.jcr/config/includes/prereq.jcr.fp_cfg.xml

    2. Copy the attached prereq.jcr.fp_cfg.xml file to that same location:

    /opt/IBM/WebSphere/PortalExpress/PortalServer/jcr/prereq.jcr/config/includes/

    3. Re-execute the upgrade. It will pick up where it left off.

    Hopefully this will do the trick.

    ~HT
    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM
  • jsuch
    jsuch
    11 Posts

    Re: Portal Express 6.1 on Linux: Update from 6.1.0.4 to 6.1.0.6 failed.

    ‏2012-11-20T16:04:04Z  
    • httweed
    • ‏2012-11-19T14:31:10Z
    Hi, this is a defect with the 6106 upgrade on Portal Express. I have attached a workaround to this post. Follow these instructions:

    1. Remove (do not rename) this file:

    /opt/IBM/WebSphere/PortalExpress/PortalServer/jcr/prereq.jcr/config/includes/prereq.jcr.fp_cfg.xml

    2. Copy the attached prereq.jcr.fp_cfg.xml file to that same location:

    /opt/IBM/WebSphere/PortalExpress/PortalServer/jcr/prereq.jcr/config/includes/

    3. Re-execute the upgrade. It will pick up where it left off.

    Hopefully this will do the trick.

    ~HT
    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM
    Hello,

    I replaced this file, re-run fixpack install and is install was successful.

    Thank you very much for your help !

    best regards
    Janusz Such