• 3 replies
  • Latest Post - ‏2012-11-25T02:41:59Z by SystemAdmin
5507 Posts

Pinned topic Urgent - Getting error while executing schedules using RPT 8.3

‏2012-11-19T12:03:19Z |

I am using Rational Performance Tester 8.3 version to perform performance testing of Java application based on HTTP protocol. Recorded two different scripts to cover all required business processes which are running perfectly during playback.

Created and executed a performace schedule with Single User for 10 iterations. We are using localhost as an agent to execute the schedule. NO SEPARATE AGENT IS USED TO EXECUTE THE TEST, However, when the test is about to complete (9 iterations were executed successfully), we have received the following error:

"Test Run stopped due to errorExecution failure. No status received from location localhost in 128 seconds. Workbench memory usage at 43.70 percent of the configured JVM heap"

On doing detailed analysis at our end, we failed to fix this issue. Attached is the error log for your refernce.

We are struggling with this issue for last two weeks. request any inputs urgently !!!
Updated on 2012-11-25T02:41:59Z at 2012-11-25T02:41:59Z by SystemAdmin
  • KMooney
    302 Posts

    Re: Urgent - Getting error while executing schedules using RPT 8.3

    The reason for recommending a separate machine be used as the agent is because the act of applying load and also the monitoring and control from the workbench can both be resource intensive operations.

    During execution the workbench and the agent exchange messages. The error message you are getting means that something bad happened to the agent process and the two processes are no longer communicating. The problem is often due to one or other of the two processes not having sufficient machine resources to complete it's task. There are a few things to check.

    First, try creating a new schedule. If any schedule settings were changed there is a chance they could be causing the agent to do work that is not strictly necessary and overwhelming it. Restoring default settings by creating a new schedule could confirm this suspicion. In particular, if not debugging the Problem Determination log level should remain at warning.

    Next, make sure you get one schedule execution to complete normally. Have the user do only one iteration or whatever it takes to get one execution all the way to successful completion. At the end of a successful execution RPT sets the property RPT_DEFAULT_MEMORY_SIZE for the maximum heap for the location. If you are selecting "run this schedule on the local computer" consider instead creating a location asset for host localhost and using it instead. Then you can verify for certain this max heap property is set properly.

    During execution use Task Manager to monitor the machine and in particular the agent java process. Look for any signs of stress such as excessive use of CPU or memory. Look at the process size to see if it makes sense based on the max heap setting.

    Look to see if the agent java process is disappearing during the run. If it goes away that will also result in the error message you are getting. If it does go away look for a javacore* file and check the contents for a reason why the process crashed.

    On the agent look for a file called CommonBaseEvents00.log (easier to find if you create a location because then you can specify the deployment root directory). It may contain messages that indicate problems occurring on the agent that could be related to the communications error.
  • prashant_RPT
    40 Posts

    Re: Urgent - Getting error while executing schedules using RPT 8.3

    Hi Gaurav,

    -->Split the test as much as yuo can and run the test for 1 iteration ...
    -->check teh kernelio file which is deployed in deployment rootand check max JVM usage
    for 1 iteration .
    --> enable the show heap status from preferences.
    --> Run the schedule and keep a track on JVM usage delete if usage is high.

    Prashant Chaudhary
  • SystemAdmin
    5507 Posts

    Re: Urgent - Getting error while executing schedules using RPT 8.3

    the problem in memory problem in your workbench

    this is the path for install folder

    path:c:/program file/IBM/sdp/rational..../eclipse config
    there you have to add one memory parameter

    Xmxnnnnm(this parameter start with underscore or not i am not sure
    u can check that in config file

    first X IS CAPTIAL
    nnnn----like 1000
    in path upto sdp was correct after that u check the path