Topic
14 replies Latest Post - ‏2012-11-20T15:03:02Z by Vipsy
SystemAdmin
SystemAdmin
1305 Posts
ACCEPTED ANSWER

Pinned topic Animation toolbar is being disabled

‏2012-11-18T16:04:54Z |
Hi, im using IBM rhapsody to create a couple of animations of state charts. I created a simple state chart with state a and state b with a transtion from a to b and b to a with event names event1 and event2. I ran the statechart and it was succesfully compiled and built. But the animation tool bar is being disabled and i could to perform any animation on the state chart. Please help.
Updated on 2012-11-20T15:03:02Z at 2012-11-20T15:03:02Z by Vipsy
  • purban
    purban
    59 Posts
    ACCEPTED ANSWER

    Re: Animation toolbar is being disabled

    ‏2012-11-18T20:32:33Z  in response to SystemAdmin
    Did you specify to include Instrumentation in the settings for the Code Generation Configuration prior to generating code?

    See the help topic:
    http://pic.dhe.ibm.com/infocenter/rhaphlp/v8/topic/com.ibm.rhp.animation.doc/topics/rhp_t_dm_setting_instrumentation.html
    • SystemAdmin
      SystemAdmin
      1305 Posts
      ACCEPTED ANSWER

      Re: Animation toolbar is being disabled

      ‏2012-11-18T20:41:35Z  in response to purban
      Yes, i selected animation in instrumentation mode before running the code and the time model is 'real'. Let me know if i need to change anything else
      • SystemAdmin
        SystemAdmin
        1305 Posts
        ACCEPTED ANSWER

        Re: Animation toolbar is being disabled

        ‏2012-11-18T20:42:50Z  in response to SystemAdmin
        Do you have more than one Rhapsody instance open?
        • SystemAdmin
          SystemAdmin
          1305 Posts
          ACCEPTED ANSWER

          Re: Animation toolbar is being disabled

          ‏2012-11-18T20:52:59Z  in response to SystemAdmin
          no, i opened only one instance Rhapsody 8.0
          • SystemAdmin
            SystemAdmin
            1305 Posts
            ACCEPTED ANSWER

            Re: Animation toolbar is being disabled

            ‏2012-11-18T20:57:45Z  in response to SystemAdmin
            So, you build the model successfully, then you ran the model but the Animation toolbar is not displayed or is disabled?
            Can you show me a picture?
            • SystemAdmin
              SystemAdmin
              1305 Posts
              ACCEPTED ANSWER

              Re: Animation toolbar is being disabled

              ‏2012-11-18T21:07:03Z  in response to SystemAdmin
              attached is the image that says the state chart build is done without errors
            • SystemAdmin
              SystemAdmin
              1305 Posts
              ACCEPTED ANSWER

              Re: Animation toolbar is being disabled

              ‏2012-11-18T21:07:46Z  in response to SystemAdmin
              attached is the image that shows the animation tab in toolbars but is disabled
              • SystemAdmin
                SystemAdmin
                1305 Posts
                ACCEPTED ANSWER

                Re: Animation toolbar is being disabled

                ‏2012-11-18T21:37:50Z  in response to SystemAdmin
                Animation toolbar become visible and enabled by running the code.
                To generate code, build the application and run the application in one step (GMR), use one of the following methods:

                1) Select Code > Generate/Make/Run.
                2) Click the Generate/Make/Run tool in the Code toolbar.

                Question: did you select the scope for your default component? (check this: http://pic.dhe.ibm.com/infocenter/rhaphlp/v8/index.jsp?topic=%2Fcom.ibm.rhp.animation.doc%2Ftopics%2Frhp_t_dm_setting_instrumentation.html)
                • SystemAdmin
                  SystemAdmin
                  1305 Posts
                  ACCEPTED ANSWER

                  Re: Animation toolbar is being disabled

                  ‏2012-11-18T23:41:54Z  in response to SystemAdmin
                  Hi I ran the code (GMR) already and was successfully built. The first picture/snapshot built.png is related to that. I changed instrumentation mode to animation. I could not find the 'instrumentation scope' link on the default config settings. Please help
                  • SystemAdmin
                    SystemAdmin
                    1305 Posts
                    ACCEPTED ANSWER

                    Re: Animation toolbar is being disabled

                    ‏2012-11-19T08:12:16Z  in response to SystemAdmin
                    The scope is set on component level (see attachment)
                    So, after you click GMR button, a command window should be open and also the Animation toolbar should be displayed (see attachment)
                    Is also the case for you?