Topic
3 replies Latest Post - ‏2012-12-05T13:11:10Z by Tony_Goodman
Gedinfo
Gedinfo
48 Posts
ACCEPTED ANSWER

Pinned topic Delete phantom object in outline issue

‏2012-11-16T15:36:10Z |
I have a DOORS module (9.4.0.0) that has a phantom object in the outline.

If I click on it, (>> Table), the cursor goes to the top of the module.

I see no way of deleting this object.

Any suggestions?

Attachment is provided
Updated on 2012-12-05T13:11:10Z at 2012-12-05T13:11:10Z by Tony_Goodman
  • OurGuest
    OurGuest
    71 Posts
    ACCEPTED ANSWER

    Re: Delete phantom object in outline issue

    ‏2012-11-19T20:55:19Z  in response to Gedinfo
    That object is the header object for a table and is not a "Phantom"; keep the >>Table if you want to keep your tables.
    • llandale
      llandale
      635 Posts
      ACCEPTED ANSWER

      Re: Delete phantom object in outline issue

      ‏2012-11-20T17:17:43Z  in response to OurGuest
      While you see table cells in DOORS, a table is also made up of an invisible row object for each row and an invisible table object for each table. It appears the table object appears in the outline, but since you cannot "see" it in the right pane, clicking doesn't know what to do so goes to the top of the module.

      Run this from a module with a table, gives an idea what is going on.
      
      Object o, oRow, oCell 
      
      for o in entire(current Module) 
      
      do 
      {  
      
      if (isDeleted(o))     
      
      continue 
      
      if (!table(o))        
      
      continue print number(o) 
      "\tTable:\n" 
      
      for oRow in o 
      
      do 
      {  print number(oRow) 
      "\tRow:\n" 
      
      for oCell in oRow 
      
      do 
      {  print number(oCell) 
      "\tCell:\t" probeAttr_(oCell, 
      "Object Text") 
      "\n" 
      } 
      } 
      }
      

      -Louie
      • Tony_Goodman
        Tony_Goodman
        77 Posts
        ACCEPTED ANSWER

        Re: Delete phantom object in outline issue

        ‏2012-12-05T13:11:10Z  in response to llandale
        Sorry this is a bit late but I don't visit much these days.

        The << Table object is indeed a "zombie" table object.
        This happens when all the cells are deleted programmatically using DXL, leaving a table object with no cells. It may or not still contain row objects, but the behaviour is the same.

        The cure is to get the table object displayed in the right-hand pane and then delete it.

        Select View > Show > and uncheck "table cells".

        Tony Goodman, www.smartdxl.com