Topic
2 replies Latest Post - ‏2012-12-05T14:27:36Z by EberhardRamm
EberhardRamm
EberhardRamm
15 Posts
ACCEPTED ANSWER

Pinned topic RDz V8.0.3.3 - IM V1.5.2: No support file locking for that location

‏2012-11-14T15:13:37Z |
When I run my silent installation of IM V1.5.2 and RDz V8.0.3.3 I get the messages below. The directory "R:\Installation-Repository-IM-V152\configuration\org.eclipse.osgi" is stored in a shared folder on a Windows 2003 Server and the local installation is running on a Windows 7 64 bit system with remote access to the shared folder.
Please can you specify in which file(s) I have to insert the VM
argument "-Dosgi.locking=none" with an example of the position in the file(s).

Invalid Configuration Location:
Locking is not possible in the directory "R:\Installation-Repository-IM-V152\configuration\org.eclipse.osgi". A common reason is that the file system or Runtime Environment does not support file locking for that location. Please choose a different location, or disable file locking passing "-Dosgi.locking=none" as a VM argument.
R:\Installation-Repository-IM-V152\configuration\ org.eclipse.osgi\.manager\.fileTableLock (Zugriff verweigert)

Many thanks for help.
Updated on 2012-12-05T14:27:36Z at 2012-12-05T14:27:36Z by EberhardRamm
  • dbehm
    dbehm
    11 Posts
    ACCEPTED ANSWER

    Re: RDz V8.0.3.3 - IM V1.5.2: No support file locking for that location

    ‏2012-11-22T13:12:32Z  in response to EberhardRamm
    I have found this technote: http://www-01.ibm.com/support/docview.wss?uid=swg21599240 describing the passing of the parameter on the command line. I am interested in your observations on this. Pls share.

    Thank you.
    Dennis
    • EberhardRamm
      EberhardRamm
      15 Posts
      ACCEPTED ANSWER

      Re: RDz V8.0.3.3 - IM V1.5.2: No support file locking for that location

      ‏2012-12-05T14:27:36Z  in response to dbehm
      Many thanks for this helpful hint. I added at the end of the IM command line for the silent installation the parameter string "-vmargs -Dosgi.locking=none" and it works fine.

      "-vmargs -Dosgi.locking=none" is needed for the IM installation folder if the IM installation folder is located in a remote NFS share on a VM image.