Topic
  • 1 reply
  • Latest Post - ‏2012-11-13T19:53:52Z by ozihcs
ozihcs
ozihcs
4 Posts

Pinned topic X240 onboard 10Gb in vNIC switch independent mode, truncated packets

‏2012-11-13T15:16:38Z |
Got a problem which I need some help with here.

The onboard 10Gb NICs on the X240 compute nodes can be set up in vNIC mode, so that each channel is split into 4 separate NICs, and each with their own VLAN + bandwidth setting.

However, when I set the server up in vNIC - Switch Independent mode, I am not able to communicate with the embedded ESXi 5.0.

SSH generates an invalid response packet error, and vcenter is unable to reconnect the server. However it does respond to ping.

Running tcpdump-uw inside the serviceconsole reveals that the packets seem to be truncated:

22:34:41.428896 IP vcenter.51752 > ESXi.443: Flags http://R., seq 1226, ack 1712, win 0, length 0
22:34:41.431412 IP vcenter.51759 > ESXi.443: Flags [S], seq 1995404931, win 8192, options mss 1460,nop,nop,sackOK, length 0
22:34:41.431456 IP ESXi.443 > vcenter.51759: Flags http://S., seq 1380158530, ack 1995404932, win 65535, options mss 1460,sackOK,eol, length 0
22:34:41.431483 IP vcenter.51764 > ESXi.443: Flags [S], seq 1359316681, win 8192, options mss 1460,nop,nop,sackOK, length 0
22:34:41.431507 IP ESXi.443 > vcenter.51764: Flags http://S., seq 1380184506, ack 1359316682, win 65535, options mss 1460,sackOK,eol, length 0
22:34:41.431548 IP vcenter.51759 > ESXi.443: Flags [.], ack 1, win 64240, length 0
22:34:41.431704 IP vcenter.51764 > ESXi.443: Flags [.], ack 1, win 64240, length 0
22:34:41.431876 IP truncated-ip - 33 bytes missing! vcenter.51759 > ESXi.443: Flags http://P., ack 1, win 64240, length 75
22:34:41.431915 IP truncated-ip - 33 bytes missing! vcenter.51764 > ESXi.443: Flags http://P., ack 1, win 64240, length 75
22:34:41.433602 IP truncated-ip - 1050 bytes missing! ESXi.443 > vcenter.51764: Flags http://P., ack 76, win 65535, length 1092
22:34:41.433689 IP truncated-ip - 1050 bytes missing! ESXi.443 > vcenter.51759: Flags http://P., ack 76, win 65535, length 1092
22:34:41.434480 IP truncated-ip - 314 bytes missing! vcenter.51764 > ESXi.443: Flags http://P., ack 1093, win 63148, length 356
22:34:41.434625 IP truncated-ip - 314 bytes missing! vcenter.51759 > ESXi.443: Flags http://P., ack 1093, win 63148, length 356
22:34:41.451132 IP truncated-ip - 49 bytes missing! ESXi.443 > vcenter.51759: Flags http://P., ack 432, win 65535, length 91
22:34:41.451782 IP truncated-ip - 49 bytes missing! ESXi.443 > vcenter.51764: Flags http://P., ack 432, win 65535, length 91
22:34:41.451864 IP truncated-ip - 256 bytes missing! vcenter.51759 > ESXi.443: Flags http://P., ack 1184, win 63057, length 298

Obviously something terrible going on, but what can it be? There's precious little else which can be configured in the CNA, and in Switch Independent mode there should be no requirements for the upstream port either..
Updated on 2012-11-13T19:53:52Z at 2012-11-13T19:53:52Z by ozihcs
  • ozihcs
    ozihcs
    4 Posts

    Re: X240 onboard 10Gb in vNIC switch independent mode, truncated packets

    ‏2012-11-13T19:53:52Z  
    Well, mystery solved. This is the same family as the Virtual Fabric Adapter series for the BladeCenter blades, and there I found a known problem with the bundled driver in VMware ESXi. Upgrading to the lastest solved the problem for me.

    Link is here: http://www.emulex.com/downloads/ibm/vfafc-software-kits/ocm6023/ocm6019-pflex-vmware/drivers.html