Topic
  • 1 reply
  • Latest Post - ‏2012-12-04T17:02:50Z by brock_smith
zelda.so
zelda.so
1 Post

Pinned topic Worklight Device Analytics data aggregation

‏2012-11-13T11:25:33Z |
hi,

when we upgraded the IBM Worklight enterprise edition from 5.0 to 5.0.0.3, the data aggregation of Worklight reports db seems to be stopped. we restarted it for serveral times, and the reporting data is still not correctly processed - other functions of the server are all running fine.

our problem is this:
we have set up the Worklight Server enterprise edition 5.0, and have configured the server based on the tutorial no. 44 (on Device Analytics) and it was running fine - we viewed the report in Eclipse Birt, and checked also the MySQL database and it was ok. but after we upgraded to 5.0.0.3, the data aggregation seems to have stopped. within the "WLREPORT" database, we can see data are still entered into the "app_activity_report" table as usual, but the data was not 'spread' onto the other tables, e.g. 'activities_cube' and 'fact_activities' - which we guess is the data that Birt displays is based on - and, when we run Birt now, we can only see the analysis of old data, until before we upgraded the server. we made change to "worklight.war" on the server as before ('reports.exportRawData=true' in 'WEB-INF/classes/conf/worklight.properties', along with other 'wl.reports.db.*' configs). is there any other files which we should configure other than the 'worklight.properties' in order to make the data aggregation run again?

thanks,
zelda
  • brock_smith
    brock_smith
    5 Posts

    Re: Worklight Device Analytics data aggregation

    ‏2012-12-04T17:02:50Z  
    Hi Zelda,
    u said that "have configured the server based on the tutorial no. 44 (on Device Analytics) and it was running fine - we viewed the report in Eclipse Birt, and checked also the MySQL database and it was ok. but after we upgraded to 5.0.0.3, the data aggregation seems to have stopped. within the "WLREPORT" database". can u please guide me where did u get the "WLREPORT" schema.i also gone through admin guide but it gone beyond!

    Regards,
    Brock--