Topic
  • 5 replies
  • Latest Post - ‏2012-11-14T05:33:00Z by SystemAdmin
SystemAdmin
SystemAdmin
340 Posts

Pinned topic CODAG085E An error occurred while parsing ILMT 7.5 agent installation

‏2012-11-12T07:44:44Z |
Iam trying to install ILMT agent 7.5 on one of the AIX (6.1)server but it has failed and attached error message.Please advise

root@jrbststdb1:/tmp>oslevel -s
6100-04-04-1014

CODAG085E An error occurred while parsing agent installation parameters.
Warning: Configuration failed! exit code 254

Finished processing all filesets. (Total time: 6 secs).

-----------------------------------------------------------------------------
Summaries:
-----------------------------------------------------------------------------

Installation Summary

Name Level Part Event Result

ILMT-TAD4D-agent 7.5.0.0 USR APPLY SUCCESS
ILMT-TAD4D-agent 7.5.0.0 ROOT APPLY SUCCESS
Updated on 2012-11-14T05:33:00Z at 2012-11-14T05:33:00Z by SystemAdmin
  • MaksKowalik
    MaksKowalik
    78 Posts

    Re: CODAG085E An error occurred while parsing ILMT 7.5 agent installation

    ‏2012-11-12T11:50:11Z  
    Hi,

    is it a fresh installation or upgrade?
    Please attach tlmagent.ini of an old agent in case it's an upgrade, and response file if you do fresh installation. Please also attach zipped /var/ibm/tivoli/common or /usr/ibm/tivoli/common

    Best regards,
    Maks Kowalik


    The postings on this site are my own and don't necessarily represent IBM's positions, strategies or opinions.
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: CODAG085E An error occurred while parsing ILMT 7.5 agent installation

    ‏2012-11-13T12:07:38Z  
    Hi,

    is it a fresh installation or upgrade?
    Please attach tlmagent.ini of an old agent in case it's an upgrade, and response file if you do fresh installation. Please also attach zipped /var/ibm/tivoli/common or /usr/ibm/tivoli/common

    Best regards,
    Maks Kowalik


    The postings on this site are my own and don't necessarily represent IBM's positions, strategies or opinions.
    Yes..It is fresh installation.I have attached your requested folder and response file.
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: CODAG085E An error occurred while parsing ILMT 7.5 agent installation

    ‏2012-11-13T12:09:04Z  
    Yes..It is fresh installation.I have attached your requested folder and response file.
    attached response file.
  • MaksKowalik
    MaksKowalik
    78 Posts

    Re: CODAG085E An error occurred while parsing ILMT 7.5 agent installation

    ‏2012-11-13T16:21:40Z  
    attached response file.
    Hi,

    please try to uninstall this agent. Then delete (if exist):
    /etc/tlmagent.ini
    /var/itlm
    /opt/itlm

    After that, you can try to install the agent once again.
    The log you attached, shows that agent installer discovered /etc/tlmagent.ini and thus assumes it has to do an upgrade not a fresh installation. What's more, the file is broken and the installation fails on configuration step. This broken file was probably created during one of previous failed installations.

    Let me know what's the result.

    By the way - your response file does not contain any non-default settings. Why to use it then?

    Best regards,
    Maks Kowalik


    The postings on this site are my own and don't necessarily represent IBM's positions, strategies or opinions.
  • SystemAdmin
    SystemAdmin
    340 Posts

    Re: CODAG085E An error occurred while parsing ILMT 7.5 agent installation

    ‏2012-11-14T05:33:00Z  
    Hi,

    please try to uninstall this agent. Then delete (if exist):
    /etc/tlmagent.ini
    /var/itlm
    /opt/itlm

    After that, you can try to install the agent once again.
    The log you attached, shows that agent installer discovered /etc/tlmagent.ini and thus assumes it has to do an upgrade not a fresh installation. What's more, the file is broken and the installation fails on configuration step. This broken file was probably created during one of previous failed installations.

    Let me know what's the result.

    By the way - your response file does not contain any non-default settings. Why to use it then?

    Best regards,
    Maks Kowalik


    The postings on this site are my own and don't necessarily represent IBM's positions, strategies or opinions.
    As per your advise,I have removed below files and directory.I tried installation after removed those files it is successfully installled.

    /etc/tlmagent.ini
    /var/itlm
    /opt/itlm
    Thanks for your prompt support.