Topic
  • 2 replies
  • Latest Post - ‏2012-12-19T10:47:05Z by tdch
F47Y_venkat_avirneni
2 Posts

Pinned topic PVU aggregation data isn't stored in NODE_PRODUCT_AGGREGATION_V table

‏2012-11-07T19:39:36Z |
We had an issue to one of our client related to PVU SUb Capacity Numbers

Issue: PVU Sub Capacity Numbers are not matching between TAD4D Audit Reports and TAMIT Audit Reports
Example S/W Product: - IBM DB2 Enterprise Server Edition
TAD4D Summary Audit Report: - Total PUV Sub Capacity for IBM DB2 Enterprise Server Edition is 2720.

After signing the PVU Audit reports in TAD4D, Imported Deployed Assets, Deployed Software’s into TAMIT using ITIC mapping
The problem is TAD4D audit report is showing the DB2 discovered capacity as 2720 whereas TAMIT audit report is showing DB2 discovered capacity as 600.

After troubleshooting these are the findings:-

1. Tad4d stores PVU aggregated data into NODE_PRODUCT_AGGREGATION_V table from which ITIC transfers data into TAMIT

2. Below query result should match the data with TAD4D reports

On TAD4D:

select SUM(p.CORES_SUB_CAP), SUM(p.PVU_SUB_CAP),, min(p.AGGREGATION_START_DATE), max(p.AGGREGATION_END_DATE), s.NAME
from NODE_PRODUCT_AGGREGATION_V p , LAST_SIGNED_PVU_MAX l ,SWPRODUCT s ,VENDOR v
where l.SUBCAP_PEAK_DATE>= p.AGGREGATION_START_DATE AND p.AGGREGATION_END_DATE>=l.SUBCAP_PEAK_DATE and
l.PRODUCT_ID=p.PRODUCT_ID and l.PRODUCT_ID=s.ID and v.ID=s.VENDOR_ID
and s.name='IBM DB2 Enterprise Server Edition'
group by s.NAME

3. Insufficient data in TAD4D aggregation tables( table NODE_PRODUCT_AGGREGATION_V) caused issues in TAMIT as ITIC transforms the same Data present in TAD4D
Anyone encountered this issue ??
Updated on 2012-12-19T10:47:05Z at 2012-12-19T10:47:05Z by tdch
  • F47Y_venkat_avirneni
    2 Posts

    Re: PVU aggregation data isn't stored in NODE_PRODUCT_AGGREGATION_V table

    ‏2012-11-08T18:21:39Z  
    attached issue in word doc
  • tdch
    tdch
    7 Posts

    Re: PVU aggregation data isn't stored in NODE_PRODUCT_AGGREGATION_V table

    ‏2012-12-19T10:47:05Z  
    It looks similar to the problem corrected in 7.2.2 FP2 or 7.5.
    Which version do you use?