Topic
1 reply Latest Post - ‏2012-11-08T18:27:13Z by SystemAdmin
SystemAdmin
SystemAdmin
603 Posts
ACCEPTED ANSWER

Pinned topic hadoop start error

‏2012-11-07T11:48:20Z |
hi,
i'm trying to start biginsight, but hadoop does'nt start this is the error message i've
when i've run start-all.sh :
INFO Progress - Start hadoop
INFO @localhost.localdomain - namenode started, pid 12513
INFO @localhost.localdomain - secondarynamenode started, pid 12714
INFO @localhost.localdomain - datanode started, pid 12852
INFO @localhost.localdomain - jobtracker started, pid 13040
INFO @localhost.localdomain - tasktracker uncertain status, 50060 not open, pid 13181
Retry the daemon command later, or tail log: ssh <node> tail /var/ibm/biginsights/hadoop/logs/hadoop-hdpadmin-tasktracker-localhost.localdomain.log
INFO @localhost.localdomain - Retry uncertain commands in a few seconds: start, tasktracker
INFO @localhost.localdomain - tasktracker uncertain status, 50060 not open, pid 13181
Retry the daemon command later, or tail log: ssh <node> tail /var/ibm/biginsights/hadoop/logs/hadoop-hdpadmin-tasktracker-localhost.localdomain.log
INFO @localhost.localdomain - Retry uncertain commands in a few seconds: start, tasktracker

ERROR @localhost.localdomain - java.lang.Exception
at com.ibm.xap.mgmt.util.TaskRunner.run(TaskRunner.java:65)
at com.ibm.xap.mgmt.hdm.HadoopMgmtFacade.daemon(HadoopMgmtFacade.java:426)
at com.ibm.xap.mgmt.hdm.HadoopDeployer.startService(HadoopDeployer.java:295)
at com.ibm.xap.mgmt.DeployManager$StartThread.work(DeployManager.java:2231)
at com.ibm.xap.mgmt.DeployManager$WorkerThread.run(DeployManager.java:2061)
<java.io.IOException: Unfinished daemon commands: start, tasktracker>java.io.IOException: Unfinished daemon commands: start, tasktracker
at com.ibm.xap.mgmt.hdm.DaemonTask.doTask(DaemonTask.java:111)
at com.ibm.xap.mgmt.util.Task.run(Task.java:77)
at com.ibm.xap.mgmt.util.TaskRunner$1.run(TaskRunner.java:52)

any suggestion?
thanks
Updated on 2012-11-08T18:27:13Z at 2012-11-08T18:27:13Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    603 Posts
    ACCEPTED ANSWER

    Re: hadoop start error

    ‏2012-11-08T18:27:13Z  in response to SystemAdmin
    Hi,

    I think the issue is related to usage of "localhost" instead of the actual IP/hostname.
    Please specify a static ip and the actual hostname in /etc/hosts (instead of specifying localhost) and reinstall the product.
    Hope that fixes the issue.

    Thanks,
    Zach