Topic
  • 1 reply
  • Latest Post - ‏2012-11-05T15:06:20Z by robtaniwa
SystemAdmin
SystemAdmin
590 Posts

Pinned topic WAS 8.5 Liberty Alfa / Eclipse Juno Install Error

‏2012-11-03T18:54:19Z |
Dear colleagues,

I've downloaded and tried to install the latest version of WAS 8.5 Liberty through the Eclipse drag feature or the Eclipse Marketplace search & install. I receive the following dependecy errors during the install step. My environment is RedHat Linux Open Client:

WAS 8.5 Liberty Install Error:
==============================

Cannot complete the install because one or more required items could not be found.
Software being installed: Web Development Tools 8.6.0.v20120926_1934 (com.ibm.wdt.webtools.top.feature.feature.group 8.6.0.v20120926_1934)
Missing requirement: Model Plug-in 7.0.400.v20120918_0238 (com.ibm.etools.webtools.model 7.0.400.v20120918_0238) requires 'bundle org.eclipse.gmf.runtime.emf.type.core [1.0.0,2.0.0)' but it could not be found
Cannot satisfy dependency:
From: Rich Page Editor - Dojo extensions 1.1.0.v20121003_0138 (com.ibm.etools.rpe.dojo 1.1.0.v20121003_0138)
To: bundle com.ibm.etools.webtools.model [7.0.300,8.0.0)
Cannot satisfy dependency:
From: Dojo Web Tools 1.0.200.v20121003_0138 (com.ibm.etools.webtools.dojo.feature.feature.group 1.0.200.v20121003_0138)
To: com.ibm.etools.rpe.dojo http://1.1.0.v20121003_0138
Cannot satisfy dependency:
From: Web Development Tools 8.6.0.v20120926_1934 (com.ibm.wdt.webtools.top.feature.feature.group 8.6.0.v20120926_1934)
To: com.ibm.etools.webtools.dojo.feature.feature.group 1.0.0

Thanks for your assistance to fix this issue.

Regards,
Claude
  • robtaniwa
    robtaniwa
    2 Posts

    Re: WAS 8.5 Liberty Alfa / Eclipse Juno Install Error

    ‏2012-11-05T15:06:20Z  
    Hi Claude,

    I believe this is because you need to be on Juno SR1 with the alpha:

    https://www.ibm.com/developerworks/mydeveloperworks/blogs/wasdev/entry/download_wdt_alpha?lang=en_us

    If you are not using 4.2.1, can you update and then retry?

    Thanks.