Topic
  • 4 replies
  • Latest Post - ‏2012-11-06T14:29:03Z by SystemAdmin
SystemAdmin
SystemAdmin
15 Posts

Pinned topic OVF package error?

‏2012-11-02T16:50:46Z |
Hello,

I downloaded the SmartCloud APM Entry Edition 7.6 beta 1 VMs and I am trying to deploy them. The vSphere client and vCenter are 5.0. When I browse to select either of the ITM or TDW image .ovf files and click Next in the deployment wizard, I get the popup error:

The OVF package is invalid and cannot be deployed.

"An error occurred while parsing EntityName, Line 528, position 22."

There is neither a line 528 nor an occurrence of "EntityName" in either .ovf file. I redownloaded the images and unzipped them twice using different tools to try to ensure I didn't just have some corruption in the file but I've not been successful. Should I be using a different client level or is there some other problem I am missing?

Thanks,
Scott Donohoo
Updated on 2012-11-06T14:29:03Z at 2012-11-06T14:29:03Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    15 Posts

    Re: OVF package error?

    ‏2012-11-05T15:05:33Z  
    I've determined and fixed the problem. The issue is that there are four occurrences of a '&' literal in the license text in the file en_US\qi-license.xml. They are at lines 528, 538, 540 and 542. If the file is edited to be '&' instead, the images will deploy successfully. I do not know if there is a similar problem in the licenses for other language support directories.
  • SystemAdmin
    SystemAdmin
    15 Posts

    Re: OVF package error?

    ‏2012-11-06T03:15:51Z  
    I've determined and fixed the problem. The issue is that there are four occurrences of a '&' literal in the license text in the file en_US\qi-license.xml. They are at lines 528, 538, 540 and 542. If the file is edited to be '&' instead, the images will deploy successfully. I do not know if there is a similar problem in the licenses for other language support directories.
    Hello
    This issue is caused by incompatible between vSphere client and vCenter. We tested on vSphere client and vCenter 4.1 and don't have such issue. We will support vCenter 5 in next Beta.
  • SystemAdmin
    SystemAdmin
    15 Posts

    Re: OVF package error?

    ‏2012-11-06T03:18:29Z  
    Hello
    This issue is caused by incompatible between vSphere client and vCenter. We tested on vSphere client and vCenter 4.1 and don't have such issue. We will support vCenter 5 in next Beta.
    Sorry, there is a typo in previous message. This issue is caused by incompatible between vCenter 4.x and vCenter 5. We tested on vSphere client and vCenter 4.1 and don't have such issue. We will support vCenter 5 in next Beta.
  • SystemAdmin
    SystemAdmin
    15 Posts

    Re: OVF package error?

    ‏2012-11-06T14:29:03Z  
    Sorry, there is a typo in previous message. This issue is caused by incompatible between vCenter 4.x and vCenter 5. We tested on vSphere client and vCenter 4.1 and don't have such issue. We will support vCenter 5 in next Beta.
    Thank you for the update. I would suggest that the documentation for the code drop also call out the expected version of VMware. There was no indication in the readme that 4.1 would be necessary to deploy the images.

    Also, I noted a typo in my post above. To get the images to deploy with V5, the '&' literals in en_US\qi_license.xml should be changed to "&amp ;" (remove the space)