Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2012-11-02T16:50:01Z by simons1
simons1
simons1
10 Posts
ACCEPTED ANSWER

Pinned topic Problem using tab on form with multiple fields (RAD 7.5)

‏2012-11-02T16:10:07Z |
I have a strange issue someone may be able to help with. I have an input form with a relatively large number of fields, and an error was reported that on entry of data and clicking submit the page was being redisplayed with all the fields cleared.

I tracked this down (eventually) to the fact that the user was tabbing between fields (perfectly correctly) and that if the tab key was used more than ten times the error occurred on Submit. Running in debug it never reaches the code behind the Submit button. I have now found this occurs on any page where the tab key is used more than 10(ish) times before submitting the form.

Has anyone else hit this, and any suggestions for a fix or work around. Currently using RAD 7.5

Thanks

Simon
Updated on 2012-11-02T16:50:01Z at 2012-11-02T16:50:01Z by simons1
  • simons1
    simons1
    10 Posts
    ACCEPTED ANSWER

    Re: Problem using tab on form with multiple fields (RAD 7.5)

    ‏2012-11-02T16:50:01Z  in response to simons1
    Forget this (if you were ever interested!). The issue isrelated to calling an "onfocus" event for each field, and calling this multiple times seems to trigger the issue.