Topic
2 replies Latest Post - ‏2012-11-29T20:51:57Z by SystemAdmin
AshutoshN
AshutoshN
2 Posts
ACCEPTED ANSWER

Pinned topic ITCAM for J2EE TEMA agent doesn't start on ITM 6.2.3

‏2012-10-29T07:48:14Z |
Hi,

My ITM version is 6.2.3 and ITCAM version is 7.1
When I try to start agent by command "itmcmd agent start yn", I get following error in log.

(508032E2.002D-1:kbbssge.c,52,"BSS1_GetEnv") KWJ_LIBJVM="/opt/IBM/ITM/JRE/lx8266/bin/j9vm/libjvm.so"
(508032E2.002E-1:kwjjvm.cpp,509,"KwjJvm::load") Loading JVM /opt/IBM/ITM/JRE/lx8266/bin/j9vm/libjvm.so
(508032E2.002F-1:kwjjvm.cpp,319,"KwjJvm::start") JVM log: ../../logs/KYN.Primary.1350578914.JVM.log
(508032E2.0030-1:kwjjvm.cpp,555,"KwjJvm::hasException") ERROR: caught Java exception
(508032E2.0031-1:kwjjvm.cpp,574,"KwjJvm::hasException") java.lang.NoSuchMethodError: java/util/HashMap.newEntryIterator()Ljava/util/Iterator;
(508032E2.0032-1:kwjagent.cpp,308,"KwjAgent::start") ERROR: internal exception in src/bridge/jni/kwjjni.cpp at line 131
(508032E2.0033-1:kwjagent.cpp,310,"KwjAgent::start") Agent stopped

When I searched the error, I got "http://www-01.ibm.com/support/docview.wss?uid=swg21595911" which says ITCAM needs java 1.5, while ITM 6.2.3 uses java 1.6.
So I set following variables in yn.ini file -

#KWJ_LIBJVM=$KWJ_LIBJVM$
KWJ_LIBJVM=/opt/IBM/ITM/JRE/lx8266_JRE_15/bin/j9vm/libjvm.so
#KWJ_JAVA_HOME=$KWJ_JAVA_HOME$
KWJ_JAVA_HOME=/opt/IBM/ITM/JRE/lx8266_JRE_15

But now I get different error while starting the agent -

(5086A4C1.002B-1:kbbssge.c,52,"BSS1_GetEnv") ITM_BINARCH="lx8266"
(5086A4C1.002C-1:kscaudin.cpp,562,"Audit_Logger::logSystemInit") ITMAUDIT: Auditing Services: Trace Level: BASIC. File Output: ENABLED. SMF

Output NOT SUPPORTED. Domain: . History Cache: 100.
(5086A4C1.002D-1:kscaudin.cpp,334,"Audit_Logger::setupFileName") ITMAUDIT: Auditing Services: Log File:

"/opt/IBM/ITM/auditlogs/anilsh.crm-portal_yn_audit.log". Maximum Size: 9437184 bytes. Maximum Files: 5.
(5086A4C1.002E-1:kbbssge.c,52,"BSS1_GetEnv") KWJ_LIBJVM="/opt/IBM/ITM/JRE/lx8266_JRE_15/bin/j9vm/libjvm.so"
(5086A4C1.002F-1:kwjjvm.cpp,509,"KwjJvm::load") Loading JVM /opt/IBM/ITM/JRE/lx8266_JRE_15/bin/j9vm/libjvm.so
(5086A4C1.0030-1:kwjjvm.cpp,514,"KwjJvm::load") ERROR: failed to load JVM. libjsig.so: cannot open shared object file: No such file or

directory
(5086A4C1.0031-1:kwjagent.cpp,308,"KwjAgent::start") ERROR: internal exception in src/bridge/jni/kwjjvm.cpp at line 515
(5086A4C1.0032-1:kwjagent.cpp,310,"KwjAgent::start") Agent stopped

Please let me know if anyone has faced such issue before ?
Thanks in advance.
Updated on 2012-11-29T20:51:57Z at 2012-11-29T20:51:57Z by SystemAdmin
  • AshutoshN
    AshutoshN
    2 Posts
    ACCEPTED ANSWER

    Re: ITCAM for J2EE TEMA agent doesn't start on ITM 6.2.3

    ‏2012-10-29T07:50:37Z  in response to AshutoshN
    I am sorry, I wrote ITCAM for JAVA by mistake. I meant ITCAM for Websphere v 7.1.
    Thanks.
    • SystemAdmin
      SystemAdmin
      800 Posts
      ACCEPTED ANSWER

      Re: ITCAM for J2EE TEMA agent doesn't start on ITM 6.2.3

      ‏2012-11-29T20:51:57Z  in response to AshutoshN
      Have you installed FixPack 2?