Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2013-01-14T13:56:42Z by Kendler
SystemAdmin
SystemAdmin
5842 Posts
ACCEPTED ANSWER

Pinned topic SCCD 7.5 Entry Edition - Self-Registration workflow error

‏2012-10-26T13:03:03Z |
A new install of SCCD-EE 7.5 using maximo security and trying to get Self-Registration working, but the SELFREG workflow is generating an exception with the following messages


BMXAA4350E - The workflow process SELFREG cannot be started in the background.
BMXAA4191E - The value 26 is not valid for Owner ID. Specify a valid value for Owner ID.


SystemOut.log shows a java exception logged at the same time


26/10/12 15:07:00:002 BST] 00000052 SystemOut O 26 Oct 2012 15:06:59:992 ERROR MXServer] [ Workflow SELFREG started in background threw an exception, unable to initiate.
psdi.util.MXApplicationException: BMXAA4191E - The value 26 is not valid for Owner ID. Specify a valid value for Owner ID.
at psdi.mbo.MAXTableDomain.validate(MAXTableDomain.java:166)
at psdi.mbo.MboValue.validate(MboValue.java:1693)
at psdi.mbo.MboValue.setValue(MboValue.java:887)
at psdi.mbo.MboValue._setValue(MboValue.java:1402)
at psdi.mbo.MboValue.setValue(MboValue.java:1387)
at psdi.mbo.Mbo.setValue(Mbo.java:2745)
etc.


The Value/Owner ID increases by one on each attempt, but resets to 21 initially after WebSphere restart.

Any pointers will be much appreciated.
Orb Data Limited http://www.orb-data.com
Updated on 2013-01-14T13:56:42Z at 2013-01-14T13:56:42Z by Kendler
  • Kendler
    Kendler
    5 Posts
    ACCEPTED ANSWER

    Re: SCCD 7.5 Entry Edition - Self-Registration workflow error

    ‏2013-01-14T13:56:42Z  in response to SystemAdmin
    hello,
    I have a similar issue.
    the problem for me is that running a WF manually (route WF) is working.
    when trying to run the WF from an automation script (MXServer.getMXServer().lookup("WORKFLOW").initiateWorkflow("<myWF>",thisMbo) )I get the same problem.
    any news about this?