Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
6 replies Latest Post - ‏2013-02-13T14:55:33Z by JBASkeen
JBASkeen
JBASkeen
137 Posts
ACCEPTED ANSWER

Pinned topic RUI Palette icons not showing when project is under source control

‏2012-10-16T19:16:53Z |
RBD 8.5
EGL Rich UI -> WAS 7

I recently noticed (again) that after putting the com.ibm.egl.rui_4.1.0 & com.ibm.rui.dojo.widgets_2.1.1 under source control into RTC that the RUI palette will not show the icons associated with the available egl RUI widgets. I have observed this problem in both RBD 8.0.x and RBD 8.5.

I understand that it may not being common to put these ibm/egl/dojo-widget projects under source control but we thought it would be best for our shop to do so that way we can control the migration of our systems from one version of these projects to the next and coordinate their release appropriately.

If this is reasonable for us to do it appears that there is some sort of underlying issue preventing the widget icons from being loaded into the palette when the project in question is under source control. We plan to start writing our own widgets at some point that we also will want to be available in the palette and will want icons for those as well while putting those source projects also under source control. Although it is not a big deal whatsoever, it would be nice to be able to have the icons available to the palette for customs widgets, and ibm widgets, that belong to a project in a repository.

I have seen this issue occur when the source projects are located in both RTC and CVS. I have attached an image showing some missing icons where I disconnected the com.ibm.egl.rui_4.1.0 project and left the com.ibm.egl.rui.widgets_2.1.1 under source control. The images shows that the one project under source control (com.ibm.egl.rui.widgets_2.1.1 ) is missing the palette icons while the other project (com.ibm.egl.rui_4.1.0) not under source control has its widget icons displayed in the palette.

Is this a bug? Can anyone else confirm this?

Thanks,
James
Updated on 2013-02-13T14:55:33Z at 2013-02-13T14:55:33Z by JBASkeen
  • SystemAdmin
    SystemAdmin
    6195 Posts
    ACCEPTED ANSWER

    Re: RUI Palette icons not showing when project is under source control

    ‏2012-10-26T02:19:44Z  in response to JBASkeen
    James,

    Could you try to press 'Refresh Palette' button to reload the widgets as attached in screen-shot (with red highlight)? Thanks.

    Rocky
    • JBASkeen
      JBASkeen
      137 Posts
      ACCEPTED ANSWER

      Re: RUI Palette icons not showing when project is under source control

      ‏2012-10-26T11:59:54Z  in response to SystemAdmin
      Rocky,

      Thanks for your response. I have previously tried this with no success. I have also verified that the com.ibm.x projects have no build issues and the paths to the icons look okay. I only experience this issue after placing the com.ibm.x projects into a repository, as soon as I do that and then refresh the palette, the icons disappear.

      Thanks,
      James
      • SystemAdmin
        SystemAdmin
        6195 Posts
        ACCEPTED ANSWER

        Re: RUI Palette icons not showing when project is under source control

        ‏2012-10-29T00:40:52Z  in response to JBASkeen
        I'll try this in my computer... Have you tried to clean your workspace, and then refresh the palette see if still have this problem?
        • SystemAdmin
          SystemAdmin
          6195 Posts
          ACCEPTED ANSWER

          Re: RUI Palette icons not showing when project is under source control

          ‏2012-10-29T00:44:34Z  in response to SystemAdmin
          I found the same issue, we'll try to fix it in next 85 release... If you want to fix it right away, feel free to open a PMR.

          Rocky
          • JBASkeen
            JBASkeen
            137 Posts
            ACCEPTED ANSWER

            Re: RUI Palette icons not showing when project is under source control

            ‏2012-10-29T13:04:48Z  in response to SystemAdmin
            Rocky,

            Thanks a lot for looking into this. We will wait for the fix to be included in 8.5.x.

            Thanks again,
            James
          • JBASkeen
            JBASkeen
            137 Posts
            ACCEPTED ANSWER

            Re: RUI Palette icons not showing when project is under source control

            ‏2013-02-13T14:55:33Z  in response to SystemAdmin
            I noticed this issue still exists in RBD 8.5.1, are there any plans to include a fix in the next release? Just curious...

            Thanks,
            James