Topic
  • 12 replies
  • Latest Post - ‏2014-11-18T15:58:49Z by HermannSW
SystemAdmin
SystemAdmin
6772 Posts

Pinned topic CLI service-quiesce

‏2012-10-16T00:50:36Z |
Has anyone successfully issued a service quiesce in fw 4.0.2 and fw 5.0.0? Following the syntax documented in the infocenter, I am getting the following error:

% (null) '<name of the service/protocol handler>' is not valid

For example
xi50mydomain(config)# service-quiesce MultiProtocolGateway my-mgpw 60

% (null) 'my-mpgw' is not valid
I thought I ask the DP community regarding the cli command service-quiesce, I might have missed something, before I raise a problem ticket with support.

Colin
Updated on 2013-02-25T15:53:39Z at 2013-02-25T15:53:39Z by Liv2luv
  • Liv2luv
    Liv2luv
    573 Posts

    Re: CLI service-quiesce

    ‏2012-10-16T13:09:35Z  
    service-quiesce command on firmware 5.0.0.1 is working as expected. Error we get when referring to a non-existing object is:

    xi50[Domain](config)# service-quiesce MultiProtocolGateway not-available 100
     
    % invalid or non-existent object [not-available] of type [MultiProtocolGateway]
    


    May be its about the resource permissions ?
    Updated on 2014-03-25T02:47:20Z at 2014-03-25T02:47:20Z by iron-man
  • Trey
    Trey
    227 Posts

    Re: CLI service-quiesce

    ‏2012-10-16T13:22:27Z  
    I tried just simple:
    show mpgw
    xi50(config)# show mpgw

    mpgw: Testing up

    admin-state enabled

    That listed out my mpgw then I was able to use your syntax on 5.0.0.1:
    xi50(config)# service-quiesce MultiProtocolGateway Testing 100

    Worked just fine as local admin id for me. You could try to list out the mpgw and then just try to change the admin state.
    See if you can make changes like that if both do not work then I agree permissions would be my suspicion.
  • SystemAdmin
    SystemAdmin
    6772 Posts

    Re: CLI service-quiesce

    ‏2013-02-22T06:19:15Z  
    • Trey
    • ‏2012-10-16T13:22:27Z
    I tried just simple:
    show mpgw
    xi50(config)# show mpgw

    mpgw: Testing up

    admin-state enabled

    That listed out my mpgw then I was able to use your syntax on 5.0.0.1:
    xi50(config)# service-quiesce MultiProtocolGateway Testing 100

    Worked just fine as local admin id for me. You could try to list out the mpgw and then just try to change the admin state.
    See if you can make changes like that if both do not work then I agree permissions would be my suspicion.
    i am facing the same issue,

    Trey,

    as per your suggestion i did try to disable the admin state and i am able to disable the admin state for a service. Is there any thing else that i may be missing here.?
  • Trey
    Trey
    227 Posts

    Re: CLI service-quiesce

    ‏2013-02-22T15:43:33Z  
    i am facing the same issue,

    Trey,

    as per your suggestion i did try to disable the admin state and i am able to disable the admin state for a service. Is there any thing else that i may be missing here.?
    If you can change the admin state and still are unable to run the quiesce command there are only a few likely causes, syntax or permissions.
    Are you using a local admin or privileged user id or do you have some RBM/Ldap auth configured?
    If you want to do this in the forum you can try to show me the outputs of:
    show mpgw
    service-quiesce MultiProtocolGateway <name> <time>

    If you would like we can work via a pmr feel free to open one and send me your error report and let me know which service you are trying to quiesce.

    I hope this helps.
    Trey
  • SystemAdmin
    SystemAdmin
    6772 Posts

    Re: CLI service-quiesce

    ‏2013-02-25T12:47:23Z  
    • Trey
    • ‏2013-02-22T15:43:33Z
    If you can change the admin state and still are unable to run the quiesce command there are only a few likely causes, syntax or permissions.
    Are you using a local admin or privileged user id or do you have some RBM/Ldap auth configured?
    If you want to do this in the forum you can try to show me the outputs of:
    show mpgw
    service-quiesce MultiProtocolGateway <name> <time>

    If you would like we can work via a pmr feel free to open one and send me your error report and let me know which service you are trying to quiesce.

    I hope this helps.
    Trey
    Thanks Trey,

    i am using the admin user with access-level privileged and i was also able to narrow down the error cause. This issue is occurring only when the "Enforce RBM on CLI" option under RBM settings is set to "on". when it is set to off the quiesce command from cli is working fine.
  • SystemAdmin
    SystemAdmin
    6772 Posts

    Re: CLI service-quiesce

    ‏2013-02-25T12:48:38Z  
    Thanks Trey,

    i am using the admin user with access-level privileged and i was also able to narrow down the error cause. This issue is occurring only when the "Enforce RBM on CLI" option under RBM settings is set to "on". when it is set to off the quiesce command from cli is working fine.
    so is there any specific access profile setting that must be enabled for service quiesce operation from cli?
  • Liv2luv
    Liv2luv
    573 Posts

    Re: CLI service-quiesce

    ‏2013-02-25T15:53:39Z  
    so is there any specific access profile setting that must be enabled for service quiesce operation from cli?
    I would try with same user credentials thru XMI:

    <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
      <soapenv:Body>
        <dp:request domain="DomainName" xmlns:dp="http://www.datapower.com/schemas/management">
          <dp:do-action>
            <ServiceQuiesce>
              <type>MultiProtocolGateway</type>
              <name>Some-Name</name>
              <timeout>120</timeout>
            </ServiceQuiesce>
          </dp:do-action>
        </dp:request>
      </soapenv:Body>
    </soapenv:Envelope>
    


    The service quiesce thru CLI appears to be erratic based on firmware. For example service quiesce works on firmware 5.0.0.1 while does not work on 3.8.2.12

    Error it throws on 3.8.2.12 is:

    xi50[Domain](config)# service-quiesce MultiProtocolGateway someMPG 60
     
    % (null) 'someMPG' is not valid
    
    Updated on 2014-03-25T02:39:18Z at 2014-03-25T02:39:18Z by iron-man
  • AndrewSimmering
    AndrewSimmering
    35 Posts

    Re: CLI service-quiesce

    ‏2013-12-11T17:55:23Z  

    Trey the master,

    I'm experiencing the same issue as the others with 5.0.0.6. I'm not even sure what some of y'all are doing because there is no quiesce on an MPGW, its on the FSH. Still, getting this:

    xi52[A_DOMAIN-WHOOP-WHOOP](config)# service-quiesce HTTPSSourceProtocolHandler A_FSH-WHOOP-WHOOP 60      
     
    % (null) 'A_FSH-WHOOP-WHOOP' is not valid

    I'm able to do it fine from web-gui and I'm using a priviledged id. Any ideas?

     

     

  • CQ9C_Renato_Zancoper
    9 Posts

    Re: CLI service-quiesce

    ‏2014-03-04T04:04:36Z  

    Trey the master,

    I'm experiencing the same issue as the others with 5.0.0.6. I'm not even sure what some of y'all are doing because there is no quiesce on an MPGW, its on the FSH. Still, getting this:

    xi52[A_DOMAIN-WHOOP-WHOOP](config)# service-quiesce HTTPSSourceProtocolHandler A_FSH-WHOOP-WHOOP 60      
     
    % (null) 'A_FSH-WHOOP-WHOOP' is not valid

    I'm able to do it fine from web-gui and I'm using a priviledged id. Any ideas?

     

     

    Any news about this?

    I know this is an old topic, but I am new to DP and just now I faced this issue, and then found this discussion.

    I am running a XI50 5.0.0.4 and I am able to quiesce a XML Firewall service from GUI and SOMA call, using both, admin and my personal privileged id, but not able to quiesce it from CLI using any of those ids.

    Is there a fix for this available?

     

    Regards

    Renato

     

  • HermannSW
    HermannSW
    6379 Posts

    Re: CLI service-quiesce

    ‏2014-03-04T08:58:54Z  
    • Liv2luv
    • ‏2013-02-25T15:53:39Z
    I would try with same user credentials thru XMI:

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr"><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"> <soapenv:Body> <dp:request domain="DomainName" xmlns:dp="http://www.datapower.com/schemas/management"> <dp:do-action> <ServiceQuiesce> <type>MultiProtocolGateway</type> <name>Some-Name</name> <timeout>120</timeout> </ServiceQuiesce> </dp:do-action> </dp:request> </soapenv:Body> </soapenv:Envelope> </pre>

    The service quiesce thru CLI appears to be erratic based on firmware. For example service quiesce works on firmware 5.0.0.1 while does not work on 3.8.2.12

    Error it throws on 3.8.2.12 is:

    <pre class="java dw" data-editor-lang="java" data-pbcklang="java" dir="ltr">xi50[Domain](config)# service-quiesce MultiProtocolGateway someMPG 60 % (null) 'someMPG' is not valid </pre>

    3.8.2.x firmware is out of support.

    If you see such a problem on supported firmware levels, please create a PMR.

    From http://www-01.ibm.com/support/docview.wss?uid=swg21414503

    • 4.0.2 (support will end on November 30, 2014)
    • 4.0.1 (support will end on June 30, 2014)
    • 3.8.2 (support ended on September 30, 2013)


    Hermann<myBlog/> <myTweets/> | <GraphvizFiddle/> | <xqib/> | <myCE/> <myFrameless/>

  • cbaja
    cbaja
    38 Posts

    Re: CLI service-quiesce

    ‏2014-11-18T07:26:33Z  
    • HermannSW
    • ‏2014-03-04T08:58:54Z

    3.8.2.x firmware is out of support.

    If you see such a problem on supported firmware levels, please create a PMR.

    From http://www-01.ibm.com/support/docview.wss?uid=swg21414503

    • 4.0.2 (support will end on November 30, 2014)
    • 4.0.1 (support will end on June 30, 2014)
    • 3.8.2 (support ended on September 30, 2013)


    Hermann<myBlog/> <myTweets/> | <GraphvizFiddle/> | <xqib/> | <myCE/> <myFrameless/>

    Hi Herman,

     

    We are running on firmware 6.0.0.1 . Even i am facing the similar issue when i try to run the service quiesce command i am getting the below error.

     

    xi50[abc](config)# service-quiesce xmlfirewall xmlfwxyz  60

    % invalid or non-existent type [xmlfirewall]
     

  • HermannSW
    HermannSW
    6379 Posts

    Re: CLI service-quiesce

    ‏2014-11-18T15:58:49Z  
    • cbaja
    • ‏2014-11-18T07:26:33Z

    Hi Herman,

     

    We are running on firmware 6.0.0.1 . Even i am facing the similar issue when i try to run the service quiesce command i am getting the below error.

     

    xi50[abc](config)# service-quiesce xmlfirewall xmlfwxyz  60

    % invalid or non-existent type [xmlfirewall]
     

    ➫  http://www-01.ibm.com/support/knowledgecenter/SS9H2Y_6.0.1/com.ibm.dp.xg.doc/service-quiesce_global.html?lang=en

    ...

    Specifies a Web Service Proxy.
    XMLFirewallService
    Specifies an XML Firewall.
    XSLCoprocService
    Specifies an XSL Coprocessor.

    ...


    ...

    Updated on 2014-11-18T15:59:43Z at 2014-11-18T15:59:43Z by HermannSW